Wemo Insight now recognized


(Nagui Anis) #1

Wemo Insight switch was recognized yesterday by ST, the interesting issue is that the ON/OFF status is based upon the load on the switch not the overall on/off status.


(Ron S) #2

I have one collecting dust somewhere. Will give it a shot. What the heck… :wink:


(Ron S) #3

@Nagui_Anis do yiu mind sharing the steps?


(Nagui Anis) #4

Just open the Wemo connect in Smartthings Labs, Discovery Started, Select Wemo Switches, it should found the Insight Wemo Switch if it was active in the network
Then you find it in the Things status icons


(Ron S) #5

Thanks… Will give it a shot if I can find the wemo…:wink:


(Nagui Anis) #6

and If you assign to it the following device type, It will also report consumption and the on/off status will not be based on load as it should really be
https://github.com/zzarbi/smartthings/blob/master/device/wemo/wemo-insight-switch.groovy


(Morgan) #7

@Nagui_Anis How is your integration of it working?

I’ve been using one for over a year, and I have a WeMo switch, and another WeMo plug. I had to remove my WeMo integration into ST because it was SO flaky, it just make it worse so I just use the Wemo app for it.

Is the integration any better or are you having any luck w/ the Insight integration?


(John) #8

Any idea why I would have problems with ST communicating with the insight switch. I have no problem using the Wemo app to control the insight, but ST almost acts like it is outside the physical range of my hub. It seems like it should communicate through the cloud or my network, not directly to the hub. (changed device type to Wemo Insight Switch, above)


(Chris ) #9

I didn’t know the wemo insight worked with st until I tried today. Maybe I’ll try that device type as it is now I can’t see the consumption. Not that it’s vital but thats one of the things I liked about the wemo app, that and the fact that it always worked.