WaterCop (Z-Wave by DynaQuip) won't connect as a valve, just a switch

Trying to include a Zwave WaterCop into my smart things hub, but it will only be recognized as a ‘switch’ not a ‘valve’. Have tried by adding general device, discovering device, going through Fortrezz/valve…have tried 100+ times - nothing works! Inclusion options do not show “WaterCop” nor “DynaQuip” specifically.

WaterCop was previously connected to a different smart things hub (~4 days ago) as a valve, so know this can be done.

Have enabled ZWave sensor, switch, and valve.

old account that this watercop correctly as a valve to is showing a different version. don’t know if that’s relevant.

Called support and they asked to move the hub right next to the WaterCop – irrelevant/didn’t work.
Awaiting level 2 callback but need to find a solution quicker.
Appreciate any suggestions!

A few angles to pursue here. First, if you have access to the old hub account still, it would be good to use either the API Browser+ or the ST Advanced Web App to see what drivers were/are installed on that hub. You could compare that list of drivers to what is on your current hub to see if you can narrow it down to a difference in drivers.

You should also look at the Z-Wave fingerprint (Mfg Code/Model) of the device (using the same sites) and post here so we can see which drivers might be the right candidates for your valve. I’ve read in other topics that this device’s fingerprints can match both a valve and switch driver. If we can hone in on the right driver, you can pre-load that driver onto your hub so that the device matches that driver first since the preference is for drivers already installed on your hub vs stock drivers that aren’t.

Lastly, there may be a community developed driver that would support your device, but I haven’t found any topic that mentions one.

1 Like

Thanks for your quick response!!

I attempted to add the device as a switch and go into the online portal to change the device manually to a valve, but it told me the fingerprint wasn’t enabled. I’m not entirely sure what that means — I did check that all the same drivers are loaded on the old and new account (including what I think is the correct driver which is zwave valve)

I’m happy to provide more information to determine what the fingerprint/Driver configuration needs to be— Does it say this information on the device itself?

The fingerprint is the Mfg Code/Model for Z-Wave and Zigbee devices. In the ST Edge architecture, fingerprint is the primary method used to determine which driver matches a particular device. If you try to change to a driver that doesn’t have that fingerprint in its configuration, ST won’t let you change to that particular driver.

The tools I mentioned in my previous post can tell you what the fingerprint for your device is. It will be in the device summary or details depending on which tool you use. Here is an example from the AWA:

Find the fingerprint for your device and post it here so we can look into this further.

1 Like

Oh ok — The manufacturer code for this device is 0084–0253 – AA08

In case its also helpful, the model is 0253 – AA08

Ok, the stock driver does not have that fingerprint. From another topic I was looking at, you might want to try the Z-Wave Valve Mc Edge driver from @Mariano_Colmenarejo. The invite for his channel is here. You can enroll your hub in that channel and install the driver. Once you do that, you can try changing to the driver using the AWA or the API Browser+. If that one doesn’t work, you should post a request to add your device fingerprint to his driver here.