Wally Sensor Integration

Has anyone successfully integrated Wally Sensors? I tried copying @jarrodmoss code (manager and device). Tried publishing to me and nothing works.

Tried the github integration and the code doesn’t show up.

Any help appreciated!

Are you wanting to connect the Wally sensors directly to the SmartThings hub, or keep the Wally hub?

It looks like the sensors are zigbee ha 1.2, so it would be pretty easy to have them work directly to SmartThings hub. But if you want to keep the Wally hub, it would have to be a cloud to cloud integration and Wally could submit that to Samsung/SmartThings themselves.

Hi! either. Ideally connect them to the smartthings hub. If they are able to connect directly, that would be great.

I found a device handler, but it’s not working.

Do you have a link to this code?

Yes, thanks!

It appears there might be a way to add sensors directly with zigbee ha1.2

I am searching for a way to do that now - foregoing the wally hub

Try adding with the ST Classic app

You tried adding the manager groovy file in My Smartapps in IDE and the device groovy in My Device Handlers? If you use copy/paste, best if you click on the raw button at the top of the page for the code, select all, copy, then paste in IDE.

I tried that, and I do use ST Classic. It fails in the authentication.

I did just pair a sensor to smart things. Attempting to find an app that will poll it now. Any recommendations?

It adds the device to the hub, i see the device ID and zigbee id. It’s set to the wally sensor. nothing is returned and i get this error:

5c5f0db1-c25b-4ad6-bf21-b87674d3cab0 11:59:08 AM: error java.lang.NullPointerException: Cannot invoke method pollChildren() on null object @line 59 (poll)

5c5f0db1-c25b-4ad6-bf21-b87674d3cab0 11:59:08 AM: debug polling

This is from the simulator.

Thanks!

You may want to try assigning one of ST stock zigbee device handlers to the device.

Awesome! just assigned a zigbee motion, temp and humidity and i am now getting readings. is there a way to edit that code? i don’t have motion, but have water detection.

Thanks!

I don’t have an answer. I will need to let someone else chime in.

I was able to setup a device handler for Wally.

It doesn’t quite work perfectly yet (needs some polish), but mostly works

Excellent!

Wally is essentially dead - no ability to log in to app etc.

How are you adding your devices (sensors)? Scanning for devices and on the sensor, do anything?

Scan for devices on hub, press & hold button on the sensor for a while; it’ll start blinking & then pair. Had no problems getting them found by the hub, but sadly as I mentioned water sensor doesn’t work well (because it’s on a different endpoint & ST doesn’t support multi-endpoint very well)

& yeah Wally is totally dead it looks like: https://twitter.com/stonerealestate/status/1322377773369954304