Wake-on-LAN Hub Action not working?


(Andrew Potter) #1

I was excited to see that Wake-on-LAN was supported by SmartThings a while ago, so I went ahead and created a smart app to attempt to wake my computer at home, but it didn’t seem to work. I then installed CoRE and tried creating a piston to do it, but that didn’t work either. Here are the facts:

  1. I’ve enabled WoL on the computer in the OS and BIOS
  2. CoRE piston was firing, and my smart app was logging
  3. WoL works when triggered from my router
  4. WoL works when triggered from my other computer
  5. Computer 1 (WoL target), Computer 2, and ST hub are all wired directly into the router

Has anyone else experienced problems using WoL with ST? I’m not sure what else to troubleshoot.


(Andrew Potter) #2

Turns out my hub was unresponsive, I just didn’t notice till I went to bed and tried to turn off all of the lights!


(Zen) #3

It sounds useful can you share the smartapp? Thanks


(Andrew Potter) #4

I copied and modified this code to set up my own smartapp: https://github.com/freethewhat/mySmartThings/blob/master/smartapps/freethewhat/computer-power-control-with-wake-on-lan.src/computer-power-control-with-wake-on-lan.groovy

If you want to use CoRE for it, there’s a great post here: https://www.reddit.com/r/Android/comments/5dwfxg/google_home_smartthings_wol_means_i_can_turn_on/da89xty/


(Andrew Potter) #5

CoRE installation guild: http://thingsthataresmart.wiki/index.php?title=CoRE#CoRE_SmartApp_Installation


(Steve) #6

I tried installing this with a virtual switch, but it never sent the magic packets to wake the PC. Any thoughts on what I might be missing?


(Andrew Potter) #7

Did you use the custom app or CoRE?


(Steve) #8

I tried your app first, and I just tried CoRE. Neither of them work. If I use a WOL app on my phone it’ll work when I’m on my LAN, so I know my computer is setup for WOL.


(Andrew Potter) #9

I’m not sure then. My issue was an unresponsive hub, so if your hub can control other things than you have pretty much the same setup as me.


(Steve) #10

Well, I fixed it. Can’t believe it, but restarting my Onhub fixed everything. All well, at least it’s working now! Thanks