VPN connection for Smart Home?


(Vic Singh) #1

I would like to get some suggestion from smart homers.
I have a Netgear R7000 with DD-WRT installed and a subscription to a VPN service. Would it be smart to connect all my smart devices to a VPN for secure connection?

Devices:
Nest
Schlage Lock
Smartthings Hub v2
Amcrest ip camera
Amazon Fire TV/Alexa
Wemo switch
Other sensors(motion/open close)
Sony receiver
Sony wifi speakers

I’m also trying to find a way to improve my VPN speed in the router because I get about a 70% speed drop.

Is a VPN connection needed for security?


#2

Your Schlage lock has a local connection to your smart things hub ( either via zwave or zigbee, you didn’t specify the model you have). So it doesn’t have its own Internet connection, it’s the smartthings hub that does.

This would be true for any Zwave or zigbee device connected to your SmartThings hub.


(Vic Singh) #3

Other than the lock which I know it is a local connection… My concern is security… I don’t want to worry about lock randomly opening.

What’s your opinion about the other devices? Is it wise to use VPN?


#4

The lock may randomly open because the smartthings cloud mistakenly sent it an instruction to do so. VPN won’t protect against that. ( this is rare, but does happen. It happened to me last November and I ended up moving my lock off of SmartThings after support was unable to find a solution.)

Personally, I think VPN is always a good idea, so if you have it, I would use it. But that’s just me. You’ll find detailed discussion of security issues in the following thread started by @slagle


(Jennifer Hudson) #5

You can improve VPN speed in the router just by seeing this tutorial https://www.purevpn.com/router-vpn.php

or contact their live support for more help


#6

Have you had any problem connecting smart devices to your Netgear router with DD-WRT? Our AppleTVs and Firestick connect, but our Nest thermostat, Bose Speakers, and Sabrent wifi receivers don’t :frowning:. Is there a setting in the DD-WRT router that I need to change? I, too, have installed VPN settings (BufferVPN), and it works, but my 5Ghz channel is not detected by any of my devices–even my iPhone, and I’ve since disabled the VPN setting. And none of my smart devices can connect to the network.

Thanks!


(Marc) #7

FWIW, I have an Asus router running DD-WRT and have no issues with Nest thermostats or other smart devices. I didn’t have to do anything special either.