New App broken when on VPN

About 70% of the time I’m on public wifi so I connect my phone to the internet over my home VPN for security. Interestingly, my home VPN also allows me access to my home network, which includes my smartthings hub.

The OLD app works seamlessly this way (which makes sense, because I still have internet access) but the NEW app doesn’t work at all. In fact is says I have “no network connection” which of course is incorrect.

Support says “Regarding operating on VPN, SmartThings does not officially support operating on VPN if the app works when the VPN is turned off, then it is working as intended.” Seems like a cop out, but there it is. So, does anyone have any insights on a) why it doesn’t think there’s a network? and b) potential workarounds?


1 Like

I use Expressvpn and have not noticed any issues. Fingers crossed it doesn’t become a problem as I have just ordered a new router with Expressvpn preinstalled on it.

I just tried the new app while routing my phone traffic over my NAS VPN server and it works fine.

what VPN server are you using? something you host? or a VPN provider?

Which model hub do you have? In the other thread that @jkp linked to, The problem seemed to be limited to those using the Samsung Wi-Fi hub which establishes a Wi-Fi mesh network. Those with other model hubs were not having a problem.

I have the v2 hub and the VPN is a self hosted solution (an ovpn solution built into the Asus router). It worked perfectly well with the classic app.

1 Like

Seems i messed up in my reply earlier.

I have a similar setup as yours. ovpn server running on my NAS and client on my phone. Can you share your .ovpn config file ( no need to share the cert nor the IP/ port of your router- remove them before sharing, I’d just like to check the config lines you have)

Here are the client setting. Thanks,

remote xx.xx.xx.xx xxxx



proto udp

dev tun

sndbuf 0

rcvbuf 0

keepalive 15 60

comp-lzo adaptive



auth SHA1

cipher AES-128-CBC

ns-cert-type server

would you have a try adding:

redirect-gateway def1

and see if any goodness?

New app not working on my Chromebook using ExpressVPN.

I’m just using Google Fi’s built in VPN that is just always on as part of Fi and that doesn’t work. That is a basic function of my phone. I think that combined with my phone running Android 8.1 causes this to trigger for me since my wife also has Fi and a newer phone and doesn’t have this issue.

It’s not just SmartThings either, there is some corporate app framework going around that is doing this. I now have 3 apps on my phone, SmartThings; ProtectWell; and Meross (Meross is now fixed), that all had the same issue and almost the same error message. These apps all report user metrics to data farming services and they try to detect if you are blocking them from spying on you.