VIRTUAL DEVICES V2: "Hub does not support edge drivers"


I just purchased a the following hub and I’m having issues when I try to install Virtual Devices V2. I have tried on mobile and on my desktop, but both results in the same error message. I’m a total newb, so it’s possible user error, but based on previous forum posts, it seems like posting here is the best way to get help?

Thanks in advance for any assistance

SAMSUNG GP-U999SJVLGDA 3rd Generation SmartThings Hub, White


what is Virtual Devices V2? do you have a link for it?


vEdge Creator’s name in SmartThings App is Virtual Devices V2

If you open vEdge Creator in App and you open using three … driver you can see that driver name is Virtual Devices V2.

I believe that it is @Mariano_Colmenarejo virtual device drive.

That would also work as well as the one the hip recommend

That’s what I’m trying, but once I am enrolled and try to install it, it fails with the error I posted previously

What is the firmware version on your hub?

1 Like

You may have to install this driver in case you deleted the main device

It can be deleted after repairing.

Hi, @newoski

As you mentioned you just installed the Hub, @jkp is right on asking about the firmware version to check that the Hub has the one that is compatible with drivers.
It should be at least the 38 but we’re currently on 47. In the ST app you need to enter the Hub, then go to its menu and select “Information”.

If you have the correct firmware update but the issue persists, I’ll report this error.

@nayelyz Thanks. I’m confused. When I go into the iOS app and then click on Hub and then Information, I see “Hub” at the top and then at the bottom it says "Controller version (2.3.17-11). Below that it says “Open source licenses”

I see nothing that looks like 38-47…


use this tool. go to Locations and click on Hub: API Broswer+

or you can use the legacy IDE (note: it is going away and I would not use it for anything else): legacy IDE
go to My Locations, tap on the name of your Location… then go to the My hubs section where you can find the version number

I gave it full access, but when I try to look at drivers, I only see this:


When I try to “Change Driver” through Devices->Hub->Change Driver, it says “Ineligible Device”

Go to Locations and select hub and check the firmware version of the hub first.

only report the firmware version… do not expose any other info on that screen :slight_smile:

Sorry, was coming back to edit post. Here you go. The plot thickens, as it just say “null”

remove that screenshot. You need to contact ST support at this point. tagging @nayelyz firmware is reporting “null” in the API Broswer+

but also look in Legacy IDE to see if perhaps it reports something different. Also you can reboot there… under My Hubs, find the View Utilities button and tap on it… on the next screen, tap on reboot hub. Watch the led lights on the hub and look for Blinking Magenta which would indicate downloading firmware. Solid Magenta indicates applying firmware. just want to see if the reboot forces your hub to call Home and check for firmware.

1 Like

Can you look at the label on the bottom of the hub and make sure that the model number matches the one you put in your first post? If you want to post a screenshot of the label, you can, but blackout the serial number on it.

M/N: IM6001-V3P01

(I followed a guide for V3)


“Controller version” refers to the plug-in that the smartthings app on your phone uses to display information about the device, in this case, the hub itself.

In your screenshot, the actual hub firmware information is blank. Which matches the “null” you saw in the API browser but implies something very strange going on.

Here’s what it should look like ( this was posted a while ago by another community member, who was asking questions about the app plug-in, that’s why that’s circled.)

Can I ask where you purchased the hub? Was it an authorized dealer?


I’m going to try a factory reset

What is your location (nearest continent will probably do)? Only the Europe, Middle-East and Africa region has hub maintenance under way at present.

After factory resetting and rescanning QR code, it now says it’s “downloading updates”. Still sitting at 0%, but I’ll take this as progress?