Anybody using ecobee thermostat?


(Surya) #1

Hi,

Did anyone manage to hookup an ecobee thermostat with smartthings? Ecobee has listed smartthings as their partner on the website. Is this functionality being worked on right now by the smartthings team?

Thanks for your time!


(Darryl) #2

Hey surya,

First, I have one. I love it. Intend to buy another one soon for my upstairs A/C.

As I understand, it is not integrated to SmartThings at this time. But I also heard that they are working on it, and it shouldn’t be long…


(Surya) #3

Thanks Darryl! Did you install it yourself? We are building a new house and I don’t want to ding any warranties doing it myself.


(Darryl) #4

Hi Surya,

Yeah, I did install it myself. I had to open the A/C unit and run the wiring. In all honesty, it was 20 minutes of work, but I did about 2 hrs of research (and calls to support) ensuring I figured out the proper wiring. My A/C unit is fairly simple, so the wiring wasn’t that bad. If your building a new house, they should be willing to install the Ecobee at minimal cost…


(Surya) #5

Hey Darryl,

Thanks for letting me know. I asked the builder who got back saying “the hvac contractor has never heard of any ecobee”…So, I might have do it after the house is built.


(Darryl) #6

Interesting. I would buy it, and ask them to install it. Its simple wiring for an HVAC contractor. It doesn’t matter if they know the brand or not. You just run the A/C wiring to the interface board, then the interface wiring (4 wires) to the touchscreen. Nothing too difficult.


(David M Clinton Stroud) #7

I have an ecobee also. I’m using two of their smart plugs which are zigbee also. I’d like to control the plugs and use the thermostat temp sensor (because the smartthings temp sensor is VERY unreliable). I tried to add the plugs to the smart hub but no dice. Do you have any idea if any of this is available or coming?


(Surya) #8

@urman, @megapixel, can you guys tell if and when the ecobee support will be available?


(Sean) #9

Hopefully we’re close to a solution. Ecobee posted this a few days ago on their FB page -> http://goo.gl/s1oWVG


(Yracine) #10

Hello, I did some ground work to create an ecobee device type.

The device type is not perfect as it still does not respond well to some basic commands like fanOn(), setThermostatMode() setHumidifierLevel(), setDehumidiferLevel(), but all the main ecobee commands (refer to the API documentation at https://www.ecobee.com/home/developer/api/documentation/v1/index.shtml) are working such as setHold(), resumeProgram(), createVacation(), and deleteVacation().

I’ve also put some logic via the iterate commands to handle multiple ecobee thermostats. I’ve not tested it myself as I own
only 1 thermostat at home, but I think that it should work as is.

I’ve reached smartthings support about the above issues, but they told me that they are also pretty close to release their own
version within the smartthings lab. Anyway, in the meantime, you can start controlling your ecobee thermostat through some of your
own smartapps!

Please refer to https://github.com/yracine/device-type.myecobee for instructions about how to set up your ecobee device type.

And, maybe, you can also help me finishing the work I’ve started!

Regards.


(Sean) #11

Looks like we have ST labs integration with Ecobee now -> https://www.youtube.com/watch?v=e1hORi6EFOw

Too bad it doesn’t work with my Ecobee EMS EB-EMS-02 thermostat :frowning:


(Darryl) #12

@sgonsalves : Are you sure? I was able to connect using the app to my EMS EB-EMS-02… I am not home to test, but it shows the temperature, system status, etc. Looks good to me at first glance…


(Sean) #13

@darrylb I’ve tried to add it a few times. After I enter my ecobee account credentials, the app connects, I click next to add my thermostat, and the page is blank. I would love to get this working.


(Darryl) #14

I would get with support on that. I didn’t have any issues. Perhaps clear your phone’s app cache. BTW… I’m using Android


(Yracine) #15

My own version of the ecobee thermostat is now fully operational (in Celsius also!)

Please refer to https://github.com/yracine/device-type.myecobee for instructions on how to set up your custom ecobee device type.

This version brings additional features over the Smartthings labs as it can also handle humidifier and dehumifier modes and levels, and “frost Control” using the setCondensationAvoid command. Here are the list of Commands available

    command "humidifierOn"
    command "humidifierManual"
    command "humidifierAuto"
    command "setHumidifierLevel"
    command "dehumidifierOn"
    command "dehumidifierManual"
    command "dehumidifierAuto"
    command "setDehumidifierLevel"
    command "setFanMinOnTime"	
    command "setCondensationAvoid"
    command "createVacation"
    command "deleteVacation"
    command "getEcobeePinAndAuth"
    command "getThermostatInfo"
    command "getThermostatSummary"
    command "iterateCreateVacation"
    command "iterateDeleteVacation"
    command "iterateResumeProgram"
    command "iterateSetHold"
    command "resumeProgram"
    command "resumeThisTstat"
    command "setAuthTokens"
    command "setHold"
    command "heatLevelUp"
    command "heatLevelDown"
    command "coolLevelUp"
    command "coolLevelDown

On top of it, any settings available at https://www.ecobee.com/home/developer/api/documentation/v1/objects/Settings.shtml
can also be used as arguments to the setHold function.

Enjoy.


(Sean) #16

@yracine I couldn’t get my EMS Ecobee to work with your app initially, I’ll try it again. @darrylb I spent hours today chatting with support trying to get my thermostat working with no success. Out of curiosity, when you go to settings/about/version on your thermostat what do see? My EMS version is 3.3.0.565 and the EI Boot is 1.1.9, I wonder if my hardware/firmware rev. has something to do my issue.


(Yracine) #17

@Sean, if it’s not working for you, let me know at which installation steps you’re having difficulties. Also, make sure
that your preferences’s verboseTrace attribute is set to true as I could then investigate your particular situation.

In order to give me more input on the problems at hand, you’d need to do a show device on your ecobee thermostat (https://graph.api.smartthings.com/device/list, and click on it) and then “list events”.

By doing so, under the verboseTrace attibute, there should be a number of events related to your thermostat. Please
post them here or pm me.

Let me know in any case, it will be a pleasure to help you.


(Sean) #18

Thanks @yracine still wasn’t able to get it working with your new code. I just sent you a PM with my events. Really hoping you can figure this out.


(Yracine) #19

@sgonsalves, I found out that I need to get a special authorization for an EMS thermostat. I made some changes to the code accordingly. Could you get the new version of my code at github and try again?

https://github.com/yracine/device-type.myecobee (copy and paste the new code in your device type and publish it again)

Hopefully, it should work now. I cannot test it on my end as I don’t own an EMS thermostat.

Also, you’d need to get a new pin for this to work…. You may want to execute the small app that initializes it again.


(Sean) #20

@yracine, you are a wizard! It worked :slight_smile: Now to figure out an app that adjusts the heat/cool temp when both my wife and I are not present, and resumes the programming when either of us are home. Thanks again for your help!