Unable to uninstall a smartapp. Lack authorization on devices, app in use and can't delete in IDE


(Ryan Kirby) #1

Hello ST community,

First time poster, though I have been going over the topics for about two months now. Thank you to everyone for helping me problem solve through your posts and discussions.

I am not a “community posting type-of-guy”, but the friendliness and openness of the ST community has been fairly impressive.

Anyway, onto my issue. I have installed a smartapp through the IDE, notoriousbdg: BatteryMonitor. It worked and works well. I, then, found I had multiple instances of the smartapp.

Upon pressing the settings button, I was informed that I do not have the “authorization” to remove the app. No big deal. I go into the IDE, find the app and commence the uninstallation. Only, the app is still in use on devices… No, it is not.

Currently, I have about 15 icons of the app waiting to be installed. That is what I get for having a persevering spirit and just enough computer skill to cause trouble and break things.

So, if anyone has encountered, heard of, solved or just know about something akin to my issue, could you please offer some assistance?

Many thanks for reading and your time,
Ryan


#2

Had a similar problem (certainly the same error) with a SmartApp and found a solution by accident. In my case the smart app had a “home” location set. I had to go into the “IDE/MySmart Apps” page and underneath the column “Location” for the app I was trying to uninstall was a button labeled “Home”. Once I “closed” this button I was able to uninstall


(Ryan Kirby) #3

Thanks for the response. I sat down to play with it a bit more and did almost the same thing.
my locations >
smartapps (within the hub you want) >
edit (beneath location photo on right side)

I was able to uninstall them without a hitch.