Unable to pair danalock v3

I am changing from fibaro to smartthings. I have a danalock v3. I unpaired from fibaro. When i try to pair with smartthings, after entering DSK, it gets stuck. Scanning the qr code doesnt work. Is there an additional step I need to do? Do i need to do a factory reset because I am changing hubs?

can you provide a few basic details:

  • which model of the ST hub (listed on bottom of standalone hubs)?
  • is the Danalock v3 using z-wave, zigbee or other?
  • stuck - does that mean it stopped at a percentage, froze up or returned an error message?
  • QR code - any errors?

factory reset of the ST is not necessary. if the lock is z-wave… a z-wave exclusion is highly recommended. in the ST app, locate your hub tile, open it, tap the 3 dots in upper right of screen, choose settings and z-wave utilities. Best results when you bring the lock and ST hub within 10 feet of each other but closer is best.


I just bought a brand new aeotec smart hub. Latest version.

Danalock is zwave. Never had any problems when using with fibaro home center 3

After i manually enter DSK, it just starts spinning and never completes. And does not timeout.

It says qr code can not be used to pair so i did everything manually.

It gets exluded properly withiut any issues. The problem is that without DSK it doesnt work and it can not enable the secure mode

Have you removed batteries from Danalock after unpairing? Each time when I unpaired Danalock from ST, I have to reboot Danalock before I was able to succefully re-pair it…

I just tried it was exactly the same :frowning:

do you have another device that you can install the ST app on and try pairing the lock?

I just tried to connect to fibaro home center 3 with S0 security mode. It connected and it is working. So definately an issue with ST

After trying many times, i got it to pass the dsk screen without getting stuck. However, end result is still the same