Issue with Danalock Z-wave

Until recently i used to have a lot of fibaro z-wave switches that never worked great for me with Smartthings. As i needed a lock i decided to get a Danalock z-wave lock as my system was primarility at the time comprised of z-wave repeaters. I bought the lock installed it and it worked great.

However, at the time Sonoff released a zigbee switch that worked locally with smartthings. As it was around 12 euros each and worked locally, something that i was waiting the Fibaro switches to get, i quickly replaced all of my z-wave switches with sonoff zigbee.

Just to get an idea of the jssue, my house is on the first floor and my front door is on ground level. Now as houses in Cyprus are built with brick and concrete, i have some serious connectivity issues with the hub. So i removed the zigbee switches from the staircase and added 2 fibaro single switches 2 in order to provided signal to my z-wave lock at the bottom of the stairs. This worked fine for a few weeks and suddenly it stopped working… i have made no changes since then. It has been almost a month now and the danalock always shows disconnected.

I have noticed in the IDE that the Danalock does not route through the Fibaro switches as it used to. I have no idea what to do at this point.

Anyone have any ideas on what i can do to resolve this? And yes i have made a number of z-wave repairs and still nothing…

What I usually do when I want to redirect the connections of the devices is remove the power of the devices that I don’t want to be used as repeaters. when the mesh has been redirected I reconnect them.
I don’t know if you can do something like this in your case.

1 Like

If the lock does not find the repeater you want, you can disassemble the switch mechanism and put the switch antenna outside the box. When it connect with the lock, reassemble it by placing the fibaro antenna as far as possible from the metal of the front of the mechanism and if you can without touching the wires.
Good luck! :wink:

The funny thing was it was working! The only z-wave devices i have left working as repeaters are the 2 fibaro switches and an aeotec siren. One of the fibaros is right next to the door and gets routed through the other fibaro switch. I don’t think this is a signal strength issue, but rather a routing one…

What do you see in the metrics in IDE?

1 Like

Which model number is the Danalock? And the Fibaro nearest the lock? And when you check the IDE, which security level is each using? I’m just wondering if there might be a zwave security level issue. :thinking:

1 Like

Does it matter? The lock is s2 and fibaro is s0 legacy. My Aeotec siren is also s0 legacy but the Danalock does try to connect theough it.




Also if i get the hub close enough, it does work…

Yes, it does matter. You’ll need an S2 level repeater.

The Fibaro FGS214 should work, or any other repeating device added at S2 level security.

1 Like

What??? But why does it try to repeat via the aeotec siren then? That is not an s2 level device.

Also if am not mistaken the fgs214 is not supported in smartthings. Is there any s2 repeater switch or device with s2 expect fibaro?

I have the same Aotec siren and the fibaro switch love her, from time to time one connects with siren and it is very far away.
If you say it was working for weeks connected via two fibaro switches and
I understand that you have another fibaro that is closer to the lock than the siren (55) and you want it to connect with the fibaro (56) and that other fibaro, which you have closer to it.
So, I would remove power from the siren (55) and do a zwave repair.

Does it actually work when routing through the siren? In both directions?

No it does not seem to work now but it was working. Also i did try to remove the siren from the network and make a network repair and it does not change. I do believe however that it was connected via the fibaro switch. Maybe the last hub firmware is to blame for this.

So the danalock could be routed from the aeotec siren but as it is not s2, that is why it is not working? Also if so why doesn’t it try to route through the fibaros?

As the aotec siren has a internal battery backup, you may have to put it in the microwave to isolate it or take it to a neighbor’s house. :see_no_evil:

I hadn’t heard that. It should work just as a binary on/off switch and as a repeater, although you might not get support for other advanced features.

As far as why it used to work and now it didn’t, it sounds like you made quite a few changes and it’s just hard to look backwards with this. I would just concentrate on trying to get it working now.

If you were in the US or the UK I would suggest just getting a plug-in pocket socket that supports S2 and putting it physically near the lock, running a Z wave repair, waiting A day or two, And then seeing if that solves the problem. But I understand that may not be possible for you in your house. :thinking:


Lol hadn’t thought of that!

1 Like

Whell i can try ofcourse. The plugs here in Cyprus are the same as the UK. I have a plug at the top of the stairs but, there is a wall separating the stairs from the rest of the house.

Any S2 UK plug recommendations that work natively and locally?

I’m sorry, I don’t know what runs locally these days. I would think the Aeotec 7 would work, but again I don’t know about locally.


Hank also has an S2 smart plug for the UK market, HKZW-SO13 , which might cost less.

Another interesting option might be to get the range extender from the ring security line. It has S2 security and is quite inexpensive. It doesn’t do anything except repeat, but I would think it would work just as a generic zwave thing with smartthings. It will say it needs its own base station, but it doesn’t, it could be added to another Z wave hub like smart things.

Ok thanks i will make some research and let you know.

1 Like

The Aeotec Smart Switch 7 fingerprints to “Z-Wave Metering Switch,” which runs locally. As for the repeating units @JDRoberts mentioned, they don’t offer any functionality where that matters.