Danalock v3 Pairing Issue - Please help!

Hi

I’ve had an Ultion Smart lock witch uses a Danalock v3 for around 10 months. I had it set up working perfectly with SmartThings, but unfortunately the motor gave way and so it was replaced under warranty.

Hard as I try, I simply cannot get the replacement to enter pairing mode. When clicking the button once to put into pairing mode, the lock only flashes green once and then nothing else happens and the hub cannot find the lock. If I unpair the lock using the smart home section in the Danalock app, the next time I try to pair, upon clicking the button once, the lock goes green and then flashes green 4 times. There is then a small break and the lock then flashes white. Clearly this isn’t meant to happen and the lock is not visible in the SmartThings app.

I have also tried pairing from the smart home section in the app but again, no joy. If I hit pair (Z-Wave) or join (Zigbee) it flashes green twice and then nothing and its not visible in the SmartThings app. I’ve also deleted the lock and started again but still, no dice!

Having reached out to Ultion, they have sent me another replacement lock and this does exactly the same thing! Given this, it makes me think that its user error rather than an issue with the locks.

I’ve found danalocks support next to useless with, days passing before a response and that response simply asks for info I have already provided!

I have also made sure that this isn’t just a bt version and it has a Zigbee mark inside and is model V3-BTZBE (the first replacement which also doesn’t work was a V3-BTZB).

Please please please can someone help / advise?!

Many Thanks

Tagging @RBoy , who is an expert on locks, in case he has any ideas.

2 Likes

You may want to try excluding the lock using the SmartThings mobile app (Z-Wave exclusion) rather than the Danalock app before trying to pair it.

2 Likes

Thanks for the response.

How would I go about doing that please? I can’t seem to find any option in the app at all!

Sorry for what I’m sure is an easy question with a blindingly obvious answer!

Just found it under the hub in devices!

See this topic, it has links on how to exclude and pair devices

Unfortunately that didn’t work but thanks for the suggestion. Here’s what I did (just to make sure I’ve done it right!):

  1. Put hub into Z-Wave exclusion made
  2. Went into Danalock app. Navigated to ‘device’ and then ‘smart home’.
  3. Selected ‘Unpair’

Is this right?

I then attempted to ‘add device’ in the ST app. I tried to add by both using a single press of the recessed button and also using the smart home section of the Danalock app. No idea why but it simply won’t enter pairing mode. I got the green light, which then flashed 4 times before a short break and it started with a white flashing light :frowning_face:

Don’t use the danalock app, use the physical lock to exclude and pair your lock and make sure your lock is within 5ft of the hub.

Thanks for coming back to me again. Sadly, still no joy.

Sadly, putting the hub in Zwave exclusion and then pressing the recessed button on the Danalock doesn’t yield any results (even taking the lock off the door and placing it an inch from the hub). :thinking:

I just can’t understand why 2 replacements would act in exactly the same way and won’t go into pairing mode but the old lock I had goes, using exactly the same actions. It’s the flashing green 4 and then a slight gap before flashing white that’s throwing me. This must be ‘recognised’ behaviour but I can’t see a single mention of it online.

Any chance someone has an older firmware file that they could send me? I could then try flashing that to see if it fares any better (I’m currently on 0.17.15). The lock I was sent was originally in 0.17.5 but supposedly the 0.17.15 was a newer firmware which seems very odd to me given how numbers work!

Willing to try anything else anyone can suggest!

Thanks again.

Try to reboot the hub and then factory reset the lock it and then pair thereafter using the scan nearby option

does the user have the z-wave version? in their post… they mentioned zigbee model.

1 Like

It is indeed a Zigbee product but the Danalock instructions say this (just to confuse matters):

How to include

To include the Z-wave or Zigbee lock on your gateway or hub, the two must be within 1 meter from each other.

Set your gateway or hub in inclusion mode first.
Then go to your Danalock app, select “Device”, then “Z-Wave” then “Connect”. (If you have a Zigbee lock, please choose “Z-wave” anyway)
Inclusion will begin. It may take some time, so please be patient.

I’m 99% sure the issue is with getting the lock into pairing mode rather than with the hub, but I’ve tried the above nonetheless, but with no luck (thanks for the suggestion in any case).

Can anyone with a V3 Danalock confirm what should happen when putting it into inclusion mode please? From memory, it should flash green until it pairs (whilst mine flashes just once or if reset it flashes green 4 times then continues to flash white). Thanks!

So, Ive managed to get hold of someone in the Danalock support team (by emailing the CEO to request help). However, still no joy connecting the damn thing!

They have told me that the online documentation is wrong and it should be set up as a Zigbee product. They have also said that the 4 green flashes and then the white is as is should be. From what I was told, the white flashes mean it it communicating with the hub. However, this doesn’t appear right to me as I have unplugged the hub when the lock is flashing white and it continues to do so, regardless of that fact it cannot be ‘communicating’ with the hub as there isn’t any power to it!

I have also factory reset the hub and tried to connect again, but still no joy. However, adding back all my other smart devices was fine which make me think its the lock, BUT because the exact same thing happens with 2 locks I still think maybe I’m doing something wrong.

When you are pairing in the ST app… does it time out or provide any info when not pairing? Have you looked in the Devices section > either in All Devices or better yet… No Room Assigned to check if it actually did pair but failed to indicate that it completed during the pairing process.

1 Like

I think you may be onto something here………

I had a device named “Thing” under devices with no room assigned. I have no idea what this is so deleted it and tried to pair the lock again.

When pairing, the hub goes into pairing mode and I get the standard screen as attached.

After maybe 45 seconds, the hub goes out of pairing mode (green light stops flashing and goes solid) but the above screen remains (and doesn’t go or will show the below eventually:

Anyway, after trying to pair again (unsuccessfully), the “thing” has appeared again under devices with no room assigned so it must be the lock……

It’s progress but no idea where to go from here!

Thanks again

Login to IDE at https://account.smartthings.com go to Devices and find Thing and click on the name, choose Edit at the bottom of the screen, change device type to Zigbee Lock and click Update at the bottom. Go back to the ST app, you may need to refresh and see if it changes to a lock you can control

1 Like

WE. HAVE. LIFTOFF.

Did as suggested and originally set it manually as a ‘Danalock’, but that didn’t work properly (wouldn’t show the status or battery level). Went back in and amended to ‘Zigbee Lock’ and it’s now working as it should. No idea why it wasn’t pairing correctly through the app but it’s working now.

Thank you so much for your help, you are an absolute star! Big thanks to @RBoy as well for your assistance.