Unable to pair/add Fibaro Relay Switch 2

Dear ST community,

I have having trouble pairing/adding a Fibaro Relay Switch to ST. I have paired more than 100 fibaro devices in my home but never a relay switch.
Is there something different that I should be aware of?
Initially I thought it was defective and I exchanged it for a new one, but I still have not been able to pair it.


  • there are multiple plugged in Fibaro devices in the surrounding vicinity working fine (1 being the AEOTECH range extender 6 placed 1.5m away with clear line of sight).
  • I have tried to factory reset
  • tried to exclude, but can not see the device to exclude it
  • have tried using the “b” button 3 times to enter pairing mode and also tried using the push button “s1”
  • I am trying to operate my sliding garage door, which also has a push button that works fine to operate the door manually.

This has been driving me nuts for months now. Any ideas?
Your help is greatly appreciated!

Update: after troubleshooting with Fibaro support for close to an hour, the conclusion from Fibaro is that the Fibaro Relay Switch is one of the first Fibaro devices ever made and most probably it is not compatible with ST hub.