SmartThings Community

Unable to get Alexa to turn off lamp I'm Routine

(Angie Guedry) #1

Hi newbie here. I have an echo dot 2 and a smartthings hub with 1 dimmable lamp module. The lamp module is configured correctly and I can turn it on or off via smartthings as well as Alexa. I added it to a new routine and the routine works as desired. Alexa sees the routine but doesn’t turn off the lamp. I’ve run device discovery several times to no avail. Any ideas?
Thanks
Angie

0 Likes

#2

Alexa can be hit or miss it seems. Have you tried the askAlexa app from here? There are several topics on it here.

Last night, I told Alexa to turn off backporch light about a dozen times and she kept replying there was no device called that. I cussed at her & she said thank you for the feedback. A few more tries and she turned off the light. Was able to turn it back on and off again without issue.

0 Likes

(3one4) #3

Is it a ST routine /automation ?

0 Likes

#4

You shouldn’t need askAlexa for that. AskAlexa is very powerful, but also requires significant technical skills including an Amazon developer account.

What’s the brand and model of the dimmer?

And can you show us a screenshot of the routine?

Also, does the routine show up as a device to Alexa if you look in the Alexa app?

If the routine includes anything other then bulbs, switches, and thermostats, than you can’t run it from Alexa just as a routine. You would have to set up a virtual switch to run it instead.

0 Likes

(Smuts) #5

I had a horrible time last night getting her to recognize a routine. For some routines I have to tell it to turn them on.

I made one call “All On”. That worked fine. But the opposite one called “All Off” wouldn’t work. Nor would “Black Out.” I changed it to “Darkness.” To get it to run I have to say “Echo turn darkness on.” That’s weird, but it worked. I didn’t add the routine to Ask Alexa yet, so I didn’t test it using that route.

0 Likes

(Angie Guedry) #6

Thanks so much everyone. Turns out it was user error. Once I told Alexa turn on routine name (in my case good night) it worked perfectly!

1 Like

#7

It would be better to use a virtual switch to turn on/off routines. Create 2 separate routines: one to turn everything on (routine 1) and one turn everything off (routine 2). Then create a virtual switch and use the SmartApp Switch Activates Home Phrase. In the Switch Activates Home Phrase settings, you would then specify that when the virtual switch is on it would run routine 1 and when it is off it would run routine 2. Then you can name the virtual switch any name you want. That way you can tell Alexa to turn it on and off using the same name.

0 Likes

#8

It just depends on the exact use case. For example, if you have a “good morning” routine and a “good night” routine you probably never need to turn them “off.” You just turn each one on when you want it.

Echo recently added the ability to run routines, and SmartThings has implemented it. This means you don’t need to go through the process of creating a virtual switch and setting up a smartapp to tie that switch to a routine.

There will be times when the virtual switch is the best approach, but also many times when just a routine will do. :sunglasses:

0 Likes

#9

I tried running a goodbye routine several times just now. Alexa replied that command doesn’t work on device. I got a push notice saying that goodbye routine was not activated because it contains locking or security devices unsupported by Alexa. I don’t have any smart locks. Closest thing I have to a security device is motion sensor. My goodbye routine just turns off all lights, sets Nest to 85, adjusts status from home to away.

0 Likes

#10

It’s probably the changing mode. When they say that echo routines are limited to bulbs, switches, and thermostats, they mean exactly that. Try temporarily taking the mode change out and see if that works.

0 Likes

#11

If I ask/tell alexa to use smarthings it will run it. It is similar wording the to askAlexa app, but I’m just asking to Alexa to tell ST without using the app. I did that before I installed the app also. Seems it needs to ask/tell ST to execute the routine instead of just Alexa, execute goodbye. To test that I took the good morning routine OUT of askAlexa, she executed the routine just by saying tell smartthings goodmorning.

Alexa, tell smartthings goodbye
ok I am executing the goodbye routine
That was Alexa straight to ST without using askAlexa app.

I’ve also been using askAlexa voice macro like below. It’s an easy way to run goodbye as you leave without setting up the routine on a schedule and gives me time to do a few things and exit.

Alexa, tell smartthings gone in 5 minutes
ok gone will be run in five minutes.

My Gone macro is set to run the goodbye routine. Lights, nest, status, and motion sensor all change as desired.

0 Likes

(Bobby) #12

You’re probably a little confused. ST uses a different skill than askAlexa. The routines with ST native app are just virtual switches. You can run them by saying Alexa: turn on [routine]. If you say Alexa tell [invocation word] to do something that is not ST native integration. Try the trick to just say Alexa turn on Goodbye…

0 Likes

#13

I did try that, many times.
Alexa, execute goodbye (used the terms turn on and run also)
Alexa replies that command doesn’t work on device goodbye, then I got a push notice saying that goodbye routine was not activated because it contains locking or security devices unsupported by Alexa

When I ask it with smartthings it works
Alexa, tell smartthings goodbye
ok I am executing the goodbye routine
That was Alexa straight to ST without using askAlexa app.

What you quoted is my askAlexa voice macro “Alexa, tell smartthings gone in 5 minutes
ok gone will be run in five minutes.” And that is different.

0 Likes