Unable to enrol to any Edge driver channels

Whenever I click on any invite links for any Edge driver channels, I receive the following error: “Forbidden. You do not have permission to access the specified invitation.”

I have tried using Incognito mode and subscribing from both my PC and phone, but I just receive the same error:

image

What country are you in?

United Kingdom

Please share a specific invitation that is causing the issue.

The invitation I wanted to follow is this one:
https://api.smartthings.com/invite/Q1jP18n4oZML

But I did also try a few others and got the same error message for all of them.

If I log out of my SmartThings account, when I follow the link it prompts me to login again, but as soon as I log in I then get the same “Forbidden” message.

I get the same thing for that particular invite. Where did you find that invitation?

Its from here: https://github.com/erickvneri/erickv-edge-drivers/tree/main/zigbee

I believe that’s the invitation URL for Erick Vneri’s Shared Drivers channel. I guess he could have removed that particular invitation URL or perhaps it has expired. Are you experiencing the same problem with other channel invitations?

Actually I’ve just tried one of my own invitations that is definitely active and I get the same error so it might just be a temporary system issue.

I’ve tried a few now and always get the same error, but maybe I keep choosing ones that have expired? Do you have an example of one that definitely works that I can try?

Ah right, perhaps it was unlucky timing!

1 Like

I think there might perhaps be a problem with invitations at the moment. I’ve just tried a test channel invitation that I have and it is giving me the same response.

Adding to the above, the API isn’t actually returning any channel invitations for me at the moment. I was reading the information from a very recent API backup.

2 Likes

From my testing, seems like some invites are working and others are not.

1 Like

I have the same problem any solutions yet?

No, but I note that I get the error when I attempt to access an accept URL for an invitation that has vanished from the API. I am, however, able to create a new invitation successfully and that one works.

Why the invitation has disappeared is a mystery.

The problem is gone for me.

1 Like

I’m still experiencing it.

I’m also having the same issue.
US based.

Problem is now back also to me.

my.smartthings_com/advanced/hubs channel links work for me.

I would suggest that channel owners consider running smartthings edge:channels:invites using the CLI to check that the invitations to use their channels are still showing for them. If they aren’t they might like to consider creating new ones and updating the advertised URLs. That should fix any immediate problem users are having. Why previously existing invitations have gone missing is another question.

The alternative to using the CLI for those who prefer a DIY approach would be to call https://api.smartthings.com/invites?resource=st1:developer::channel/{{channelId}} for each of their channels.

3 Likes

Came here to report I am having issues with invites as well. Will SmartThings fix this issue or do the devs who handle their channels have to fix it?