Unable to access SmartApps settings

Hey guys

I integrated Github with my ST hub yesterday, in order to get Rule Machine working. All was working fine, up until publishing the app, when my hub suddenly went offline. Now when I log in, and go to ‘My SmartApps’, I can’t see my Github integration - and I can’t re-add is as the settings button is now missing from the page.

I’ve rebooted the hub a few times, tried logging in with different browsers etc but nothing has worked so far.

Does anyone have any tips on how to get my SmartApps settings button back, and to re-integrate Github?


ok how do you do it? I have not been able to integrate yet. I click the Enable GitHub integration button and it takes me to the main screen for ST thats it

I followed the instructions here - after enabling GitHub integration you have to link ST to your GitHub account. I don’t remember being returned to the main screen - the whole process was pretty easy when it worked.

thanks I tried that an no go oh well. copy and paste for me

I’ve found a way to get the ‘Enable GitHub’ option to reappear :

  • Logout from graph.api.smartthings.com.
  • At the login screen choose forgot password.
  • Click the link in the email you receive.
  • Enter the new password (can be the same as the old one) and then login.
  • In the ‘My SmartApps’ page, ‘Enable GitHub’ has reappeared :slightly_smiling:

A) The option disappears again around 30-40 mins later, so I have to perform these steps again
B) I’m now stuck at the next step (Enable Source Code Control), as ST wants me to add it as a collaborator to a repository I don’t own, and can’t edit.

I’ve deleted/recreated my GitHub account, so I know ST isn’t using my current repositories, and must be using cached details.

  • Does anyone know how to clear the cached GitHub details in ST?

I have a similar problem. I can either see my Hub and devices, OR my smartapps and Handlers. When I can see my devices and Hub, the settings button (as well as 2 others) disappears in smartapps. It’s like I have 2 accounts linked to the same email address. When I “forget my password” i can see the github integration but not my hub. but as soon as I click on “locations” it witches across to the ‘non github’ side?! so weird.

I have the same problem, how to fix this??

I had someone from Samsung reply to say that there is a conflict if you have both a Samsung account and a Samsung Smartthings account. Until they unify their systems, they didn’t have a solution for me. They aslo didn’t say how far off this transition would be.