GitHub Integration Button Redirects To Login Default Screen


(Curtis Williams) #1

Hey Guys,

I have fiddled too much with ST/GitHub. So I removed integration from ST side and when I tried to add a new one… it redirects to default login style page.

So I then revoked application / removed repository in GitHub.

Still nothing.

Just trying to get back to wizard setup.


(Eric) #2

I tried to setup Github integration for the first time last night (for Rule Machine) and got stymied. I don’t think it’s something you or I can fix.


(Curtis Williams) #3

Somehow it was already working and I FUBAR it.


(Matt) #4

if you notice on GitHubs site they do not list smartthings for integration.


(Curtis Williams) #5

There is a literal Enable GitHub Integration button in smart things.


(Matt) #6

I know but I wonder if GitHub has stopped adding new st connections.


(Eric) #7

Now I think I just didn’t get it the first 9 times. I had to add a repo “SmartThingsPublic” and add a collaborator, just like the prompting screen said. The path just wasn’t familiar. Now my IDE has the expected integration buttons.


(Alan Penner) #8

I’m getting the same thing. I had GitHub integration, wanted to start over, so I disconnected the repos. Now it just redirects me to the main screen when I click the integrate button.