Tuya Water Sensor Not Behaving Properly (keeps going offline)

I have a number of these water sensors:

They work perfectly, however, they do not appear to ‘report status’ often enough, and SmartThings thinks they go offline. When they do report status, then SmartThings says they are back online.
So all day long, they go offline, then online, then offline, then online, then offline, then online.
When they are reported as ‘offline’, I have dropped them in water as a test, and the second they get wet, they imediately report ‘online’, then ‘wet’. So the devices work perfectly, they just don’t report often enough for the driver to think they are working.

I’ve tried the default ‘Zigbee Thing’ driver
I’ve tried the ‘Zigbee Moisture Sensor MC’ by Mariano
Both behave identically, the only difference is the icon that shows.

I want to re-iterate, this is NOT a connectivity issue. I’m positive of that. By watching event history, I can see every single device cycle offline/online in regular intervals. I’d bet my paycheck this is simply a matter that the ‘keep alive’ signal just doesn’t report to SmartThings at the frequency that SmartThings wants. I say this based on the regular frequency that every device goes offline/online, and the fact that all other devices never drop offline.

I am a software developer by trade, and really wouldn’t mind digging into the driver and fixing it. However, I figure I can’t be the first one with this issue.

Correct: you are one of dozens, if not hundreds. Just search the forum for “offline“ and you’ll find more threads than you can count. But unfortunately none of them will help. :disappointed_relieved:

“Off-line“ status is a construct that SmartThings has developed for themselves and it just doesn’t work great. There have been at least four official announcements that they were going to improve the algorithm, but people keep reporting issues like you have seen. And, yes, it’s usually just that a device doesn’t report quite the way that SmartThings expects, whether that’s a timing issue or something else.

The problem most commonly occurs with inexpensive Zigbee devices, including tuya made devices like the one you have, but it can occur with others as well.

Some specific models do have custom Edge drivers which can adjust the reporting frequency, but at the cost of battery life and it doesn’t always work.

So you have three options

  1. try to find a custom edge driver that works with the model and then ask the author if there’s a way to adjust the reporting frequency. But there may not be.

  2. try a different repeater, usually a smart plug of a different brand. Sometimes this helps, sometimes it doesn’t. For example, some people find that IKEA Smart plugs are very good repeaters while others find that they are problematic. Remember that you will have to do a Zigbee heal each time you add a new Smart plug or physically relocate one.

  3. check to see if the sensor model is one which works with a matter bridge from Tuya. If so, connecting it to that bridge and then bringing it in to SmartThings that way usually takes care of the off-line problem.

1 Like

I just decided to ignore the notifications by disabling them for those devices in settings. Notification history fills but my phone and tablet keeps quiet. I hope this will be fixed someday.

1 Like

Have you reported this to the driver team? If not, I will. This should be a super easy fix.

Where in settings? This is all I see?

Not all device manufacturers offer firmware which allows the reporting frequency to be changed. Typically, this is out of a desire to protect the battery life to avoid customer dissatisfaction or sometimes to meet safety certification requirements. Sometimes, it’s just a cost savings issue: devices that can change these kinds of parameters have to be smarter, which typically increases developer costs.

As always, the first rule of Home Automation applies: “the model number matters.“

1 Like

As you probably already know, all of the “MC“ edge drivers are community – created by Mariano. Have you tried asking in his author thread to see if there’s a way to change the reporting frequency with that driver? He’s usually very responsive if parameter setting changes are possible. :thinking:

(EDGE Driver-Mc): Zigbee Drivers for Motion, Open/Close, Moisture, Smoke-Co Sensors and others Devices

1 Like

It’s in SmartThings general settings: Menu>gear icon>Notifications>three dots>Notification settings. There you can enable/disable notifications per device.

I think the two of you are talking about two different device classifications.

Your method will turn off all notifications for the device running the SmartThings app (your mobile, or tablet).

The OP is, I suspect, looking for notifications for the individual end device, in this case, a leak sensor.

I may be mistaken, but I don’t think there’s a way in SmartThings to turn off notifications for just one end device. :thinking:

edited to update: as @Olli-Pekka_Kurppa points out below, the app does have the option to turn off end device notifications on a device by device level. My apologies for any confusion and I appreciate the correction.

1 Like

I plan too, I just wanted to see if anyone else did. I too am a developer, and I know it can be overwhelming to have a dozen people ask you the same exact question.
So before I asked, I wanted to see if the question was already asked.

1 Like

Correct, I ONLY want to turn off that device, not everything.

1 Like

If you go to notification settings in SmartThings app (I’m on Android) you really don’t see individual on/off switches for each and every device (sensor, switch etc) you have in your ST system? Or do you mean that you have already switched off notifications for your troublesome water sensors, but those still notify offline-online constantly?

Wow— I didn’t know that was there! On iOS, it’s there, but you have to click on “Filter” to get to it and it’s not obvious that that’s actionable for the purpose of turning off individual device notifications.

Thanks for the correction! :sunglasses: