Tuya Multi Switch (MoesHouse 2-gang switch) shows up as "Offline"

I have a couple of MoesHouse Tuya multi Switch devices (2-gang switches). I bought one and tested it and it worked, so I bought a few more (10), but I can’t get these to work.

All the HW details are identical:
HW Decriptor:

  • _TZ3000_pmz6mjyu
  • model: TS011F

The first one apperaed as a “thing” and I got working as a standard “ZigBee Multi Switch” + child. When I tried to install the second and third one I had this device handler installed that was supposed to be able to support these directly:

It found the switches and installed them as Tuya Multi Switch + child but then they went offline.

I removed the device handler and repaired, now they appeared as “thing”, and I managed to install them, but they immediately go offline again. I have checked the packaging and everything is identical on them, the same with the actual switch.

Does anyone have any ideas?

It’s probably this:

Thanks. Even though it is a huge problem, at least I know why…

1 Like