Trying to change my TV input back with alexa

I’ve set two activities within harmony one which says turn on Netflix at which point it goes through all sequences and dims my hue lights to a low red. my watch TV activity sets mode to hdmi and channel 705 and bright white light. similar sequence. my question now is if I turn on Netflix my input stays there so when I turn off netflix and turn on TV my lights change back but it opens up netflix still. is there a activity or method to change back to hdmi 1 when I say alexa turn off netflix or even better go from Netflix straight to TV without turning off then on because of smartthings. having fun but help!!!

I’m new to the whole harmony thing. Still learning like you. Could you not have the TV select the proper HDMI input as part of your TV start activity?

Also I think when you turn on one activity it turns off the other. So say you turn on TV it should close Netflix activity (run the exit commands)and start the TV activity (run its start commands).

I’d recommend finding the Harmony ,Alexa thread and asking in there.

EDIT: look / ask in this thread.

OR here:

So each activity can change an input. So when you switch to TV it should switch inputs if you set that up.

Is Netflix on your smart tv or on a AndroidTV, firetv etc?

Samsung suhd smart TV. When I say turn on TV (activity which changes channel and lights) it does as said but the TV just stays on that input because I think it’s still considered hdmi 1 it’s just a selection on my TV. I’m thinking I need to play with exit commands from Netflix activity to change back to the proper TV input cable option which is still hdmi 1

So Netflix AND your regular TV are both on HDMI 1 input. Your switching it someplace else? Or are you saying Netflix is built into the TV so it doesn’t switch inputs?

My Vizio TV has a button on the remote to run Netflix, is your something like that?

Just create another activity to do what you want using the commands function

Netflix is built into smart TV and is on the same input. It’s just an app like YouTube or hbo go and stuff. When you click smart TV a bar opens up and the first option says hdmi then every option to the left are all my smart apps like Netflix which is one selection to the right but still on hdmi. My activity for Netflix opens up my TV then smart TV then with delays I have programmed it to move one right then select and poof there’s my Netflix and red lights but when I switch to watch TV activities my lights change and my smart TV bar loads up and just hits select as its supposed to.

Netflix is an app in the smart tv. has nothing to do with inputs.
TV activity has to switch to an input, unless you tell harmony not to do it.
To switch activities without turning tv off, go to harmony, select your tv and under power options select to keep it on when changing activities.

So you got it figured out?

Or upon returning back to the TV from Netflix do you need to program left to select HDMI (TV) again.

Copy what you manually do to get back to TV when you do it. Then program that step by step in harmony, you did for Netflix.

And do like @NomadTech says to keep the tv from cycling power.

OK so here’s what I’ve done now. It’s a step in the right direction. I made a end sequence in harmony so when I say alexa turn off Netflix goes through its programed sequence which puts my lights back to normal and adds a step to go left to tv/hdmi select then turns off. That works now because I can now say watch tv and it does what it’s supposed to. So I guess I’m close to what I want. I run this all through smartthings so I’m turning off one activity and then turning on th other activity. I’m now going going to work on going from my Netflix theater mode to watch the TV mode without shutdown sequences and more of a transfer of activity. Thanks for everyone’s help I do read and take the advice but don’t have all that much time to do trials and replay back. Here we go thanks )

1 Like

Hello all

A newbie here. I read the posts above but remain unclear so I thought I’d horn in and explain my situation.

So, here is the current setup and what I’d like do. Currently, when I select watch tv all of the devices, tv monitor, cable box, and stereo turn on and the correct inputs are activated.

What if like to do…

I use my computer to stream content which is viewed on the tv monitor, with sound coming from the stereo. I am trying to set up commands or activities that would allow me to change the tv monitor input to HDMI II and the stereo output without epithet device turning off then on.

I have gone through the device setup for the tv and stereo and changed the setting so that it is always on until the off button is selected, and I tried leaving on always and neither option works.

It may be important to note, I previously used a harmony 700 remote and supply copied the settings to the new remote which is a harmony companion and hub.