Harmony + Amazon Echo


(gary) #1

Every time I try to have Alexa do a harmony activity (turn on tv) it says can find tv in my profile. Alexa can turn on lights etc…but nothing with harmony. Smartthings can can complete the activity just not Alexa. Anyone have ideas…


(Brian Diehl) #2

Try changing the name of the activity to something without TV in the name. Or make it T.V. I believe was also a recommended suggestion.


(Matt) #3

Look in your Alexa app on your phone and make sure it is hearing you correctly. Mine thinks when I say ON I am saying off. Not overly impressed yet


Harmony issues
(Michael Hess) #4

I actually just redid all my Harmony integration so I could add a third Harmony Hub and clean up a mess I’d made before. I deleted devices from the Alexa SmartApp, all the SmartApps for Harmony, all my virtual switches, all the Harmony virtual devices. Removed all entries on Alexa app. Clean slate as it were.

Reconnected Harmony via the SmartApp and had it create all 17 of my activities as virtual devices again. Renamed them, take off (Harmony Activity,) and named TV to Watch TV.

Verified my remote’s, Harmony App’s, and ST worked on all activities.

Updated Alexa SmartApp to include the activities and did discovery.

Everything works great except she says “That command doesn’t work on device xxx” on certain devices, and seemingly randomly. That message doesn’t stop the activity from starting or stopping though.

I should also point out I had to try about 4-5 times to get ST to save the SmartApp after discovery, it’s always been flaky with that though.


(gary) #5

Changing the name works…NOW saying “turn off” Sports (name for tv) turns it on and and “turn on” turns it off…its backwards…SMH