Trouble (re)associating WD500Z dimmer with Aeon Minimote & SmartThings v1

I’ve had a working Z-Wave setup for five years: Linear WT500Z 3-way switches, several with associated WD500Z dimmers. When I first set things up, I used an Aeon minimote to associate each dimmer with its master switch. Later, I added a SmartThings v1 hub.

Everything’s mostly been working fine. I had an “all downstairs lights off” automation that stopped working somewhere along the line. The SmartThings app changed a few times. Nothing that important broke, so I just left it all as-is.

About a month ago, almost all of my remote dimmer switches just stopped working. I can still turn on/off lights from the masters, but the dimmers don’t do anything. Only one pair continues to work.

Attempting to re-pair with an Aeon minimote isn’t working, and enough things seemed to have changed in the SmartThings ecosystem that I’m not sure if what I’m trying to do is even possible any more. I could use some advice, since searching turned up lots of articles from 2013-2015 but nothing worked & I don’t know if they’re are still relevant.

All switches are powered. The minimote -seems- to be working. Exclusion/inclusion causes blue/red lights to flash as expected. An excluded master switch still turns on/off the lights, and though the switch remains visible in the SmartThings app, I can no longer use the app to control the switch.

Association via the minimote begins, but can’t complete: press Associate (blue light blinks slowly), double-tap the dimmer switch (blue light blinks faster), double-tap the master switch … nothing changes. I’ve tried excluding and re-including both the dimmer and master, still no association.

Note that I’m trying to do a z-wave association, not ST automation aka “follow”. I read a few threads that said this was no longer supported, etc. but I can’t see why it shouldn’t be since I still have the same hub and minimote that I originally used to set the system up.

Final questions:

  • Are the dimmer switches supposed to be discoverable and show up as their own ST device? (they don’t)
  • Are changes I make with the minimote supposed to be reflected in the ST app? (they’re not)
  • Is there some chance that the ST hub is interfering with the process? I don’t know that much about how z-wave actually communicates with/without a hub.
  • Is there any kind of diagnostic utility I can use to investigate my system, beyond the two SmartThings apps?

Thanks for any advice!

It should still work since it’s the same devices that you set up originally, but since it’s not working, there is a new utility, created by a community member, that you can use both to do the diagnosis and to do the zwave direct association without having to use the Minimote.

To use the utility, which is a device type handler, you just temporarily edit each device in your account that you want to check to use that DTH, set the associations the way you want them to be, and then change the device back to your every day DTH. You can get the code and ask any follow-up questions in the following thread:

You could also just use the tweaker to see how the associations are currently set.

Meanwell, I’m confused by your description of what you’re doing.

First things first: you must have included both devices before you begin trying to do the association. That’s because they both have to belong to your network and have a network ID. From your description, it sounds like you might be trying to do the association before you’ve done the inclusion. Also, the minimote has to already be included on the same network. Finally, when you do a Z wave association using a minimote, you first press the target, and then the trigger. So first, tap the master switch. Then tap the accessory. From your description, it sounds like you’re doing it the other way around, which won’t work.

so the steps would be:

  1. make sure the minimote is active on your network

  2. exclude both switches

  3. include both switches

At this point all three devices should show up in the things listed in the app. (The master switch, the accessory Switch, and the minimote)

And both switches should be controllable individually from the app.

If this is not true, stop. You can’t do the association until both the master and the accessory can be seen as individual switches by your network. So you need to get them both included.

Once all three devices are successfully joined it to your network then you can associate them using the minimote

  1. a) put the minimote into association mode
    B) double tap the paddle on the target device, the master switch (WD500). It will blink blue rapidly
    C) double tap the paddle on the trigger device, the accessory switch (WT 500)
    D) take the minimote out of association mode

See the community FAQ (this is a clickable link)

Thanks for the fast reply! Your past posts have been really helpful too, I found a lot of them while searching… including your FAQ on these specific switches, thanks!

You’re getting into a lot of the things I thought might be wrong, so I’ve already done a little bit of exploration:

I -think- I’m doing the association while the device is included. But the master switches directly control their lights even when they’re excluded, and the dimmers never work, so I don’t know how to prove the devices are actually included or excluded. All I can see is from the minimote; it’s reporting success when I include or remove, but it reports success if I include multiple times in a row, so I’m not sure what to make of that. I was just assuming that if the last thing I did was an include, it “took”.

More clues: the specific pair of light switches I’m testing on were -not- visible in the ST app when I started. Others were, so I excluded one of them using the minimote, just as a test. The minimote reported success, but the device did not disappear from ST. I used the app to remove it from ST, but had to “force remove” it. Now I can’t get it to add again, ST never finds the device :frowning:

I thought that the minimote was on my network, because I explicitly added it as a device and ST did find it and add it to the list. It reports it as having 4 buttons and doesn’t record any history of button presses, but I don’t know if it’s supposed to.

From your message these are the takeaways I’m going to try next:

  • the pair of switches are -not- visible in ST, so I have to make that happen before it’ll work
  • I got the target/trigger order backwards, although I hadn’t mentioned that I had tried it both ways, at least I know which order to do it in now.

Some other possibilities I’m chasing down:

  • I thought maybe the minimote was on some other network, and maybe I’m joining all those lights to some other ID that ST doesn’t recognize. But if that were the case, it’s strange that I still can’t get them associated on that network.
  • I couldn’t figure out how to go into “general exclusion” mode so that I could reset the switches and see if I get them individually re-added through the ST app.
  • I see people having trouble with proximity, so I’m going to move the ST hub into the same room as the problem switches for a bit.

Meanwhile, my setup’s current state:

  • One successful pair of switches in the kitchen, which show up in the app & are controllable - they show up as a single device.
  • One unsuccessful pair of switches in the kitchen, which was showing up in the app as a single device that I could control, but I guess in my testing I broke them because they’re now “unavailable”
  • One unsuccessful pair of switches in the kitchen, that was not in the app even before I started my fixing.
  • One unsuccessful pair of switches in the dining room, which don’t show up in the app at all.
    So I know that at least some minimum network is up and running correctly, it’s not anything about the network being completely out of range of the ST hub or anything…

Sorry for all the random details, just trying to post anything that might help, while I dig into your suggestions. Thanks again –

The master switches are regular mechanical switches in addition to being zwave. They should operate the lights they are wired to even if you unplug the hub altogether. So that’s normal.

If you can’t control the devices from app, they are not on your network.

It sounds to me like you have a bunch of leftover ghost devices from when they were previously on the network and that you may have reset the switch so that now it is trying to join under a different network ID. That would explain why the one in the app doesn’t do anything.

I suspect you just need to take a deep breath and go back to the beginning. I suggest making a checklist of all the switches and checking off the steps so you don’t miss any.

1a) Start one by one with the switches and use the General Exclusion to exclude them one at a time. You can do this from the minimote as long as the minimote shows up in your things list or you can do it from the hub.

1b) As you go along, also factory reset each switch. These are two different steps, so you need to do both of them, although the order doesn’t matter.

Note that these first two steps only change the information that is stored inside each switch. They don’t change the information that the hub has stored.

Throughout the process the master switches will always work on the lights that they are directly wired to, that has nothing to do with your network.

  1. now look at which switches you still see in the app. One by one, go through those and use the zwave replace to see if you can “replace“ the switch with itself.
  1. if there were any switches which didn’t still have a placeholder in the app, now go through one by one and just add those.

After you’ve gotten those three steps, you should have all of your switches showing on the things list in your app and you should be able to turn each one on and off from the app, although turning the auxiliary switches on and off may not do anything yet since they are not yet associated to the Master.

Once they are all controllable from the app, then you can follow the steps we’ve already discussed to set up the associations.

I’m concerned about the ones that you say “show up as a single device” if you gave the model numbers correctly, that’s not what you would see. It is what you would see for models which have dumb auxiliaries like the GE switches where only the master switch has a radio. Then only the master shows up in the things list. But for the Linear/gocontrol devices, both the master and the auxiliaries have a zwave radio and each one has a network ID and should show up on your things list. You can’t associate something which doesn’t have a network ID.

Thanks. Meanwhile, I installed Z-Wave Tweaker from the groovy source, and it shows up in my app, but on any button press:

5:06:01 PM: error java.lang.NullPointerException: Cannot invoke method startsWith() on null object @line 1619 (initialise)

which is interesting because line 1619 is inside initialise method, but isn’t calling startsWith. I’m gonna put that aside while I try the restart you’re suggesting.

By any chance did you install the tweaker as a smartapp instead of as a device type handler? It’s a device type handler. To get to it you select the device that you assigned it to from your things list. You can ask any questions about it in the author thread and people should be able to help. It’s a very popular utility. :sunglasses:

I added it as a Device Type Handler from code, pasted in the groovy code, and then added a device from the IDE with Z-Wave Tweaker as the type. It’s pretty cool learning about the IDE! :slight_smile: But I could have made a mistake when I added the device, the instructions are a bit loose there so I just chose reasonable-sounding values. If I did something dumb like mess up the code while pasting it, I can probably track it down when I have some time, but it seems lower priority than doing the reset.

Right now I’m trying to figure out how to do a factory reset (your step 1b) on these switches, if you happen to know how to do that for WT500Z/WD500Z that’d be great, otherwise I’m searching around for info…

Also, I do see the minimote as a device in the ST app, but I can’t see it actually doing anything. “Recently” is empty except for the single event from when I paired it this morning (“Number of buttons is 4”). Is it supposed to log button presses? Or is there some other way I can use it to prove it’s actually on my network?

If it’s listed, it’s on your network, unless it’s a ghost representation from a device that was previously on your network. You could try setting up a smart lights animation and make the button press do something to see if it’s working.

re: appearing as single devices, I never (even when originally set up & everything worked) saw 2 devices per pair, it’s always been a single entry for “kitchen light”, for instance.

I could imagine that’s because I never actually added the dimmers to the hub? I didn’t think I’d have to. Also, my network was working before I added ST, so maybe it didn’t discover the dimmers. I really don’t remember much about when I did the initial setup, unfortunately :frowning:

Hmm. I created an automation, set it to run “when a button is pushed”, the Minimote button 1 is available so I set it to that. Pushing the button doesn’t run the automation (I confirmed that the automation can be run from the app, it unlocked my zwave lock.)

Everything is pointing at the minimote not being on the network. I’m going to try taking it off the network and then re-including it.

1 Like

update: I’m not sure what this is -supposed- to do, but I went to the minimote in the ST app, and chose to Replace. The minimote disappeared instantly, with no other feedback from the app. I’m not sure if that meant it identified an already-missing device & cleaned it up, or if unpairing is just that fast. It’s no longer listed on my network, so I’m going to add it again.

update 2: Added the minimote again, now it’s logging button presses, and it can run automation.

1 Like

First, just to get this out-of-the-way, you can only associate something which is on the same network. It has to have a network ID assigned by the hub. So both the trigger and the target devices have to be on the same network.

Second, you can forget everything I said until now, because I misheard the model number. I thought you were using the accessory switches, which are the WT00Z. Those are the ones that can do association.

It sounds like you have some master dimmer switches (WD500Z) and some master on/off binary switches (WT500Z/WS15Z)

neither of the master switch models can do association. It’s the accessory switch that is the trigger for association.

So you must’ve just physically wired them to the same circuit. That’s why you didn’t have to add the second switch to the hub.

I have no idea how you have that working, it’s not what they are Spec’d for. So you’ll need to talk to one of the electricians in the community like @Navat604 To figure out what’s gone wrong.

Sorry for any confusion - the two parts are indeed:
WD500Z, the master dimmer switch,
WT00Z, the remote accessory switch. (I don’t have WT00Z-1s)

update; oh, sorry, yeah, I’ve been writing WT500Z instead of WT00Z. But to confirm, I have the associating accessory switch, not the -1 models.

Further updates: now that I have the minimote on the network, I went around and re-included the switches and dimmers and they did show up on the network as individual devices (“Z-Wave Dimmer” and “Z-Wave Switch”) although I can’t yet figure out which one is which :slight_smile:

The only one that failed to include (minimote didn’t show success, it doesn’t show up in the app) was the remote switch that I was actually testing on earlier! Going to look into that after I try associating these pairs.

Thanks for all of the help so far, really appreciate it.

1 Like

Whew! OK, then at some point you definitely added them to the same network. The way association works is the hub gives the trigger device permission to send a basic command to the target device, with each device identified by its network ID. The network IDs are assigned by the hub at the time of joining.

But maybe you added them with the minimote and didn’t realize you had done that. ( that’s what the “include“ button does, by the way)

Still… They should show up on the things list.

But maybe you added them with the minimote and didn’t realize you had done that. ( that’s what the “include“ button does, by the way)

I definitely did do this myself five years ago (the inclusion process and the association process), so that’s what I was trying to re-do today as a fix. After all this diagnosis I’m pretty convinced that I just never recognized that -each- switch was actually registered in the app. I have a lot of ghost devices from failed attempts all those years ago… :slight_smile:

1 Like

Final update … for now!

Once I confirmed the minimote was up & running correctly on the network, I was able to use it to fix every switch -except- the one accessory switch that I started testing on. There’s a chance that there’s something separately wrong with that switch, since the same procedure that worked on every other switch isn’t working on it.

A lot of my confusion came from not understanding how precisely the state of SmartThings reflects the state of the Z-Wave network – thank you so much for guiding me through this and telling me what to expect!

The accessory switches do now appear on my network, they just don’t show the current state of the switches/lights they’re associated to, so they appear to “do nothing”. Back when I first set this up, I had renamed the master dimmers to the names of the lights they controlled. While it’s pretty obvious in retrospect that the system doesn’t actually know the state of the lights themselves, just the switches that control them, it meant that the un-renamed accessory switches kinda blended in with a lot of other ghost devices I had from having tried out various Z-Wave things in the past. I’ve cleaned all of those out now to make it easier to see the truth!

I still don’t know why those switches all “fell out” of the network at once, but at least my wife can turn on the lights in the kitchen again :slight_smile: And I’ve learned about the SmartThings IDE and might play around a little more with that…


1 Like

You can use the official smart lights feature to have the accessory switches mirror the activity of the master switch and then the statuses should be in sync, if you care. (The downside of using Z wave direct association is that since the messages don’t go through the hub, The hub doesn’t know what happened.)

The status of the master switch should be the same as the actual light being on or off since it is controlling the current to that light. :sunglasses: