Trouble pairing GE Smart Switch (Model 12727)

Get an Aeon minimote, great for adding devices not so close to the hub.

Thanks for the tip, I ended up here when I was having trouble adding my first 12727 switch. This worked for me perfectly!

Yes, that is the switch that I have. Resetting it has “fixed” the problem, so far.

1 Like

Thanks for this tip. My house is ~35 years old. We switched the load and line wires and we also replaced the neutral wire with a copper one. And after this the hub found the new ‘thing’ quickly, only one or two toggles on.
Thanks again.

This worked for me. Thanks!

1 Like

This worked like a charm. Was about to take them back. Thanks a ton xjonx!!

1 Like

Thanks for your help. I wish I saw your post hours ago. Thanks again.

1 Like

This was the answer. Thank you!

I found out what the problem actually is. This switch need to be close to the hub to pair. In my house I was a floor down and about 40 feet away. Since the switch need power I could not just move it there. So I made a pigtail to connect the switch to an ordinary power outlet. The load does not need to be connected. I ensured that I had correct polarity by operating the switch and hearing the relay inside clicking. I plugged the pigtail into an outlet near the hub and then I was able to pair. I removed the pigtail, installed the switch in its original location and now it did work.

The GE instruction should say that it needs to be close to the hub to pair.

I have 3 of these GE switches and they were no trouble to pair initially. One of my GE switches got excluded while I was trying to exclude a different device. I guess the switch “raised its had” first and got excluded. It was completely removed from my app and hub. I have been trying relentlessly for 2 hours to pair the switch with the hub without any luck. The switch is within 5 feet of the hub. I tried the 4 up / 4 down manufacturer reset and a search for the specific device from the marketplace, and the ST hub still wont find it. Any other ideas or tips? I am thoroughly frustrated and thinking about returning the GE switches for something else.

1 Like

I never got a clear answer from ST support, but ultimately, I had to explicitly exclude each switch and then re-add them back to my hub. This was very frustrating because it meant I had to rebuild any automation that include these switches. So once I knew what to do, getting the switches working again took a few minutes each. However, getting my system back to full functionality took days. Very frustrating… :rage:

Up to this weekend I have never had a problem pairing all my GE switches, dimmers and fan controls (about 28-30 devices).

This weekend I have been installing more devices and I’m having some troubles. In one room (closer to the hub than the furthest already installed/paired GE device) I put in a switch in a single gang box and a dimmer and fan control in a two gang box. The dimmer and fan control have paired just fine but the switch will not.

In another room (again, there are GE devices physically further from the hub), I did the same thing as the other room. In this room however the single switch paired fine but the dimmer and fan control would not pair.

Okay, well I have never run a Z-Wave repair (never had troubles so never saw the need) so I did one and tried to pair the dimmer and fan control again that would not previously pair. After several tries the fan control paired but the dimmer would not. The switch in the first room still wouldn’t pair either.

All newly installed GE devices are functioning manually just fine.

Any clues? This is driving me mad.

I’ve sent this one to Support with more information from my logs as this has me baffled. I can’t have two bad switches out of 6.

I am seeing issues with my Z-Wave Repair too I believe. Hopefully Support can see what’s going on.

Posting the reply from Support as I think it may be helpful to some:


Thanks for reaching out to SmartThings with all these great details! I’m sorry to hear that some of your GE Z-Wave switches and dimmers are giving you a hard time connecting, but I’m happy to help out.

Based on the data from your Z-Wave network repair, it sounds like all of the current devices in your network are routing signals back to the Hub using the best route possible. To explain the “skipped” device IDs that you noticed: sometimes when a device pairs or is successfully excluded, it will get assigned a device ID from the Hub. When the device no longer is on the SmartThings network, the device ID is gone and does not get recycled unless you start your Z-Wave device table over again. Likely there was either a partial connection that did not go through or a previous device was assigned that ID. This is pretty common in large Z-Wave networks and likely should not cause any problems or is something to worry about.

Looking at this data, there are likely two things going on here: the switches are not receiving exclusion commands properly, and there may be interference from other nearby switches. With two devices near each other, it may be the first one that connected is now drowning out the signal from the Hub for the other one.

Another thing to note is that exclusion commands cannot pass through repeaters, unlike most other Z-Wave commands. Let’s go ahead and test for this, as well as for interference from other switches by trying to bring the Hub within 10 feet (it may need to be closer than this even) and trying the exclusion process for those switches again at that distance.

Please let me know what time you try to bring the Hub closer to the switch and begin General Device Exclusion. This way I can take a look in the event logs at what activity happened in your Z-Wave network at that time. Looking forward to hearing back from you.


My reply:

Thank you. That did the trick.

One of the devices paired right away with the hub closer. The other I had to do an exclusion on first and it did find an ‘unknown device’ to exclude this time. It then paired.

What threw me is I have other devices quite a bit further from the hub’s usual place. But, what was different this time is I was activating 3 devices at a time. I believe I have usually installed one at a time.

Things seem okay now. The hub is back in it’s normal place and all are paired and are responding to commands.


Now I can get on with the remaining 9 devices I have. Thanks Lowe’s.

Thanks for this thread!

(1) My initial problem was that the GE Smart Switch not even passing power to the single outside garage light. I saw the comment about the required neutral connection for this type of device, and that fixed my problem. I get that not all possible customer configurations can be accounted for, but there was nothing in the GE install instructions that said the product would not work w/o a neutral connection.

(2) My ST v2 hub refused to see the newly installed GE Z-wave switch - doing the steps of excluding general devices, turning the GE switch on/off a few timers, and then manually adding the device from the Marketplace-Switch-GE Smart Z-wave Paddle Switch page solved the problem.

Thanks again for the help.

Thanks Jason,

Your suggestion seemed to have worked for me as well, I was trying to follow their GE instructions i.e clicking 10 times after pulling the reset/tab. Unfortunately i didn’t have any luck with that.

Anyway, Thanks for your help.

Best!

Also be aware that a loss of utility power to the switch (brownout, blackout, maintenance/repair, et. al.) tends to cause the most problems on the connection.

Be ready to reset the switch with these instructions after such an occurrence.

This is intriguing and will look into getting this remote.

I eventually fixed it by logging into the smart things IDE and removing the device. It wasn’t showing up in my app but was still connected to hub.

Years later, this thread continues to be useful. I had spend hours trying to get the GE switches to work with SmartThings before reading this…