Trouble Controlling Leviton DRZ15 outlet

I’m attempting to add the Leviton DRZ15 outlet to my smartthings hub. I can see the device on the ZWave network and can add it to my devices. The problem I have is it won’t let me control the device. I can’t turn on or off the device that is plugged into the outlet. If I push the programming button the device turns on/off. I just can’t control it with my smartthings hub. Suggestions for troubleshooting?

Edited to add this first:


I haven’t looked up the specs on this particular device, but some duplex receptacles only offer zwave control for one of the two, or slave the second to the first.

Usually the top is the controller. But that could mean the lower does what the first does, or it could mean the top is zwave controlled and the bottom is not.

Receptacles where each plug is independently zwave controllable cost more and have a different device type.

So first things first: test with something plugged into each receptacle and see if you have control in one or the other. But you may have already tried that.


This may not apply in your case, but another common reason for seeing this Behaviour is because the device has been moved since it was initially included, and so it has different neighbors than the routing table says it does, and so the hub messages never reach it.

A similar situation occurs if a repeater was in place before and has since been moved. This could then cause the routing table issue as above or could just mean signals can’t physically reach the device.

In either case, what the dashboard shows you is the device as it looked when it was included, but not how it is now.

Since this a zwave device, the easiest thing to do is reboot the hub, then do 3 consecutive heals (under zwave utilities), allowing for 15 minutes between each one. (You don’t need to reboot the hub between heals.)

What this does is allow for all the hops on the network, as well as any battery powered devices that might be asleep when you start the heal.

It takes some time, but it’s physically pretty easy.

(If you want to clean up most zigbee routing table issues at the same time, just make sure you leave the hub off for at least 15 minutes during the reboot.)


If you haven’t moved any devices since the original pairing, you could just reset the device to its factory settings and then include it again. The instructions that came with the device will tell you how to do this.


When I do the zwave repair. I get the “failed to update mesh info” message.

I’d open a support ticket, that doesn’t sound like a problem with the Leviton. :disappointed:

Installed one of those myself last week. Quite the challenge. At first I had the same problems as you describe. I moved the hub closer (about 10 feet) and now I could turn it off but not on. Moving the hub 15-20 feet away and I could operate the device entirely. I then moved hub back to its original place and the device to another switchbox in the same room but on a wall 90 degrees to where it was first installed. Before installing directly into the metal box I tried operation the switch from my mobile. Worked like a charm. Installed switch into metal box and once again I could not turn it on but could turn it off. Rebooted the hub and voila… has worked 70-80% of the time.

Into an outlet in between the DRZ15 and the hub I plugged in a Leviton DZPA1 socket. Now my DRZ15 works flawlessly as do other devices installed within that room.

That trick worked. I added another device between the Leviton outlet and the hub.

Thank you for the suggestion.

It’s really common for a networkable device installed into a metal box, as happens with in wall wall switches, to have a lot of the signal blocked by the box itself. True for any network, regardless of the hub you’re using.

Another plugged in device of the same protocol (that is, zigbee for zigbee, zwave for zwave) nearby that can act as a repeater for messages from the hub can really help.

You can also experiment with placement of the repeater. A lot of times placing it across from the switch on the opposite wall gives you a good result, sometimes it’s best on the wall 90 degrees from the switch.

In a few cases it’s the switch plate cover that’s blocking the signal and you can try a different style. In particular, metal covers can be a pain, and just changing out to a plastic one solves the problem. :blush:

You are an absolute genius. My zwave network started acting nuts tonight. I couldn’t get a repair to complete properly. My distant devices weren’t working, even my near by device was out. This one worked if I unplugged something from the slave. I have been scouring the forums to figure this out and Bam I put a metal plate over one of my outlets earlier on. The minute I took the plate off my entire system was back in business.