Trouble Adding Hue Bridge to SmartThings

SmartThings says that I need a SmartThings Hub to add my Hue Bridge which makes no sense.

There are four different ways to add a Hue Bridge to a SmartThings account. Some require a SmartThings/aeotec hub, some do not.

  1. add via “linked services“ which will make a cloud to cloud connection between your SmartThings account and your Hue account. No ST hub required.

  2. create a LAN connection between your Hue Bridge and a Hue hub. Obviously, this requires a SmartThings hub.

  3. use the community created custom edge driver. Since all edge drivers require a smartthings hub (that’s where edge drivers run), this will require a smartthings hub.

  4. add via Matter. SmartThings connects to matter devices via edge drivers, so again, a smartthings hub is required.

FAQ: What do I need to add a Matter device to the SmartThings app? Do I need a bridge router device?

———
So, if you don’t have a SmartThings/Aeotec hub, then your only option is the cloud to cloud “linked services“ method.

  1. Open the SmartThings app. Choose “add device“ with the +.

  2. choose “partner devices”

  3. choose Philips hue from the list of partners.

  1. now you must choose “linking your account.“ Any other option on this page will take you to one of the methods that requires a smartthings hub.

Continue that process and you should be able to link the accounts.

3 Likes

Im not getting an option to link accounts. It just says i need a smart things hub to add my hue bridge

Did you follow the exact steps I listed above? Any other pathway will require a hub.

Are you able to see the screenshots I posted? The “linking your accounts” option is in tiny print and fairly hard to find.

Can you post screenshots of the exact steps you are using, starting from when you first open the SmartThings app?

Do not click “Next” at the bottom of the screen if you want the cloud to cloud integration for Hue. It has been one of the most poorly designed UI for years. :slight_smile:

1 Like

They’ve changed things. Now, if you don’t have a hub on the account at all, you do have to click “next” at the bottom.

the screens look like this.


.

I was not able to get to the same screen that the OP has, so that’s why I asked what exact path was used. :thinking:

this is what I see:

which matches your first post.

That’s because you have a hub on that location.

We have two locations. The first has a hub, the second does not.

The first set of screenshots I posted were from the first location. On the screen for that location, clicking next will start the processes that require a hub.

The second set of screenshots I posted were from the second location. You can see that there are fewer options and the wording is just a little different: there’s no “also “. Clicking next on that screen will start the process that does not require a hub.

And it’s still a terrible UI. :man_shrugging:t2:

It wont let me post multiple pictures since im a new user, but i followed your steps exactly

It could be a problem that only appears in some versions of the app.

My screenshots are using the latest version of the iPad iOS app.

Which version are you using?

I’m also using the latest version on android