Triggers using Ecobee3 Remote Sensor?


(Jason Coleman) #1

I am just getting around to getting my Ecobee3 integrated with my ST hub. I’d like to use the temperature of one of the remote sensors as a trigger for activating another device (temp on remote sensor > X activates a outlet in the room with a fan plugged into it). But I haven’t been able to see a way to do it because the individual remote sensors don’t seem like they have enough functionality associated with them to drive that kind of behavior, from ST or via IFTTT.

Is this something I can do? I’m guessing I might need to use some other integration device besides the official one, but I’m not sure, there’s a lot of Ecobee threads so it’s been a lot to sift through.

Thanks!


(Amauri Viguera) #2

I think the ecobee remote sensor refresh rate was pretty abysmal, IIRC, so while it was decent to manage the present / away status for the thermostat, it would be terrible for more time-sensitive stuff.

I could be wrong though… maybe things have changed or someone hacked their way into a higher refresh rate, but I believe that it was done for a reason – namely to conserve battery life.


#3

What he said, I was looking for this information yesterday also since I just installed mine. I was hoping to use the remote sensor as an alternative motion sensor for the rooms.


(Jason Coleman) #4

Ecobee API documentation states the refresh rate to be 15 minutes, which for my purposes is fine. So I 'm back to the question of if it’s even do-able with the current state of the Ecobee integration.

But, I’m also on an automation kick again, so I may just pick up a new sensor if I can drive it with a different sensor.
Thanks


#5

Have you checked out @yvesracine apps, that may be what you need.


(Yves Racine) #6

Hi @viguera, @jason_coleman ,

The ecobee temp sensors can be refreshed every 5 minutes w/o any issues. The main lag issue
is with the remote motion sensors as there are some ecobee API limitations as stated at the ST community
wiki:

http://thingsthataresmart.wiki/index.php?title=Ecobee3RemoteSensorInit#Known_issues

So, the remote motion sensors cannot be used for real time HA scenarios as there is a minimum of 30 minutes lag for the ecobee3’s smart away or follow me features. Actually, some ecobee3 users observe
sometimes up to a 2-hour lag before the smart away feature kicks in at their home.

See this thread for more details on the lag issues from another specialized forum:

http://www.smarthomehub.net/forums/discussion/352/smart-home-away-not-working

My smartapps, which leverage the unique set of features of MyEcobee device, can reproduce the smart away & follow me features within few minutes (configurable option) with any ST connected sensors.

See this thread for more details:

Regards.