Temperature sensors not beein able to use decimal in routine

Hi. A few days ago did my routines which involved temperature trigging stop working. Realised it was due to the routine not reading decimals on temperature. Before could I use for example 22,5 degrees Celcius to turn of heating. Now does the routines only work with whole degrees. For exampe 22, 23, 24 degrees celcius. Does others see the same issue? This must be a bug? In all temperture routines do I now see that they only work from -20 Celcius to 50 Celcius. Dows anyone know what has happened? The APP version is running om Samsung S21+

iOS or Android? What version of the ST app?

If android… users are reporting various issues with the latest version…

Do you mean you cannot enter a decimal number when creating a condition? It is still OK when working in UK English.

I can enter a decimal and I can save the routine. But it will not work. When I go back and edit the routine, the routine crashes when I try to enter a different temperature.
Will se if there is coming a fix then. Thank you

It must be a problem introduced in the latest version.

try entering the decimal with a “.” instead of a “,” this is working for me

In my location the decimal is “,” but with new version I have to use the “.”


Strange thing. I tried to enter “.” insted of “,”, but the app reverts it back to “,” automatically.
When you go back to your routine, may you edit the temperature setting, or does the app freeze?

Yes, the edition of values with “,” crash.
The you can do: go to “,” position and delete the “,” then write “.”

See video

Let’s hope they fix it soon

1 Like

I wonder if this is only related to non-US English versions or both. You can test by setting your phone to US English.

1 Like

Hi. I tried that, but when i saved the change did it again get reverted back from 22.5 to 22,5
I changed the default language now to english-UK and now it works. So there must be a language setting-bug in the last version. thank you for your help

1 Like

Yes, it must be a language setting bug in the last app update. I changed my phone to default language English-UK and now it works. Thank you. Hopefully samsung will fix this

1 Like

Hi, can you try to submit the report, please?
The team mentioned they were able to submit it from the mobile app.
Please follow these steps:

  1. First, reproduce the error so we can get fresh logs of the issue registered.
    a. This will imply going back to the language that causes the issue and trying to set the decimal number with ,.
  2. In the SmartThings app, go to “menu”
  3. Select “contact us” > “report a problem”
  4. When prompted “create log?”, click on “ok”
  5. Wait a few seconds, select the corresponding browser if your mobile device asks
  6. Once you’re on the “Customer Support” page of SmartThings, select at the bottom “contact us/Error reports”.
  7. Then, fill up the form on the next page and click on “submit”

Please let me know if you could complete the process

What language were they using? As noted above, the behaviour when the language is set to UK English is different than when the language is set to something else. :thinking:

1 Like


I set the system language back to norwegian.

Same problem with “,” reappears.
No logs are beeing created.

Just beeing sent to a page that does not work.

See the attached screenshots.


When I switch back to English-UK:

If you have given in to repeated pestering and installed the Samsung Members app, Menu > Contact Us in the SmartThings app stops showing a useful menu and redirects you to a totally useless Samsung Members page that is of no use for contacting SmartThings support.

Until I removed the app yesterday I’d never seen the menu with ‘Report a problem’.

1 Like

Hi just tested the “send error report” with English-UK as system language.

The logs are not beeing created and the form for sending errors is garble.

Originally did I go to https://www.samsung.com and hit support. I managed to create a ticket.

The next day did I receive an email from smartthings UK support.

They told me, that they could not help me, as I was supposed to contact the norwegian smartthings support. Did then take contact with samsung Norway support, and they only respond on dishwashers. Refrigerators, tvs, smartphoned and ACs. Pretty frustrating…

The smartthings UK support could not forward my ticket to any other support centers.

This happens from the android app:

I guess samsung members works differently from the different location.

Is there any news regarding the “,” and “.”?

Edit: Have now also tested with my wifes Samsung A52s. Exactly the same error there with “,” and “.”. And also no logs beeing created and the form is also garble.


Yey! The send logs function from the smartthings android app works now, so I just sent the logs. Looks also like the hub it self works with “,” decimal settings and the routines seems to work again. However, the android app does still not support “,”

Thank you for that. The Customer Support Team mentioned that they already reported it. When you submitted the report, did you receive a ticket number?
I think the Customer Support Team will contact you directly and you will be able to follow the status of the issue with them.

Thanks for replying Nayelyz.

There is no ticket number in the “Samsung members” app. There is only a generic “thank you for your feed back. We will answer you as soon as possible”.

Attached is the Norwegian reply


Outlook for Android