Temperature format - one showing C, another F

Sorry for the confusion! US and UK run separate hours for live chat. The chat platform used in the UK is different from that in the US and is not set up for in-app support. If you update the SmartThings app, the link has been removed to prevent further confusion.

Additionally, if customers accidentally contact the wrong country, the other team would typically provide you with initial troubleshooting steps and do a more subtle handoff. However, the C/F issue appears unique to the UK (or at least not trending in the US) and we are still looking for a fix/workaround (and root cause) in the UK. @adgwill - it looked like J wanted to get you bumped over to our agents right away and T & I are digging into this with the engineers on your behalf.

Thanks,

Is there a solution to the C/F problem yet? I am seeing the same thing.

I’m also seeing this issue, where my location is set to C. My motion sensor is now showing temperature in C but my multi sensor is still showing F. In addition, the software colour ramp is confused by Celsius values - it’s showing the colour as if it was am F reading - i.e. 22 © is showing dark blue (extremely cold) whereas it’s actually 72 (F) and should be showing with a green (i.e. normal temperature).

Hi @Ollie

I never heard back from Support and just removed & re-added the sensor a few times and after a couple of tries it started reporting back in ©. I would strongly suggest trying the same & will keep my fingers crossed it resolves for you also!

I wonder if by re-adding the device after the default temperature format has been set to degrees C makes a difference.

Ant

Yes, this makes a HUGE difference.

I had the exact same problem - Added sensors, then changed my Location preferences to C from F, and my sensors were still showing F. Which was a bit of a shock, as I have a multi sensor in my fridge to alert me if the door is left open, and apparently my fridge was at 49 degrees…

I noticed that if I put a temperature offset in, it changed it to C - I put -3, and instead of dropping to 46 degrees it went down to 4 or something. So I took the offset out, and it stayed at C.

With my moisture sensor, I just put an offset of 0 and it forced it to C.

I’ve been having this issue too since I first got SmatThings. Fixed with todays update :grin:

My temperature sensors all show the correct temperature with a ‘C’ but notifications and text messages show ‘F’ after the same figures. I must plead guilty to initially setting up with F before realising where to set things up for C.

I’ve had this issue and tried various combinations of the tricks in this thread with no proper results.
Started out with multis in F and switched to C in the site. After some days they switched to C, but at this point I realised my movement sensors were still in F.
Left it for a while longer.
Found my site setting was back in F again, switched it back to C.
Now my movements are in C and my multis are F.

I’ve bee in contact with support and they’re aware of the issue and that it’s being worked on. They say they “don’t have enough pointy stick” to keep on at the devs, I’ve suggested perhaps tin cans on string would promote some two way comms but apparently there’s no schedule for a fix forthcoming.

I’ve also got Honeywell Evohome and waiting for that integration before this becomes too annoying.

It’s now been months that this thread has been running, is anyone else still having these issues?

Thanks,
Iain.

The challenge had been with pinning down the root cause. It’s not clear if this is happening on the platform side or with the device handlers. Keep emailing support@ when it occurs so we can trend events. Thanks!

I’m using the UK Hub V2. For Multipurpose Sensor, firstly temperature was in Fahrenheit. Then I changed it to Celsius on Location Settings. But it was still showing in F.

Then I removed the sensor & paired it again and it’s now showing the temperature in C.

I did nothing, just waited a further two weeks and today my sensors are all in Celcius. Long may that continue.

I.

When I first installed it was F and changed setting as per help pages and waited for next temp change to trigger change and it didn’t work. I then removed the sensor and repairs by taking battery out and it was C. To be fair future sensors all reported in C from the get go.

Hi all,

I had the same problem as above… temperature was in F. What I did was:

  1. opened website: https://graph-eu01-euwest1.api.smartthings.com
  2. loged in with smartthings login and password
  3. once you are logged in on the website navigate to the top left corner and click on “My Locations”
  4. once the new pages opens, under the picture click on “Edit”
  5. then from the dropdown menu under “Temperature Scale” choose C
    6.Click on update.

Now you have to remove the sensors from the Smartthings app and add them again. (it won’t work otherwise).
After all is completed and after the first activation of the sensor the temperature reading will be in Celsius.

Hope this helps!
Mack

4 Likes

I had a few sensors randomly change over to F after working for months on C. Had an alarm go off that a few rooms in my house going from 25 to 80 degrees. Had a panic and thought there was a fire. Disgusted with this and removed the alert from SHM as it was too stupid to realise the change from C to F being the cause. Yet another reason not to rely on ST for alarms.

can you send a ticket in to support@ with the approximate time/date and DM me the ticket number. I want to flag this for investigation.

Unfortunately this was many weeks ago now so it’ll be fruitless I’m afraid. I just remember the panic it caused me while we were all out at the time.

@Aaron just had this at 2am in the morning causing a siren alert. Was not popular with the family especially after the disruption caused by the firmware update already.
I sent the email to support regarding this with screenshots but no response yet with ticket number.

Please submit a ticket to support and DM me the number. I’ll flag this one for an escalation

It’s 2024 and still no sign of resolution which shows they really listen to people