Teckin Power adapter conects to router but wont pair with app


(Dai Croke) #1

I have tried many time to get these units {Teckin Power Adapters model SP3} to pair via the app.

  1. I have tried both the Ez and AP method.
  2. They connect to the 2.4gz SSID of the router {They show in the route as Legacy devices and have 100% signal strength. Linksys X32 router}.

Any help welcome {Have been trying for 2 days}


#2

Which model of smartthings hub do you have?

You should be able to get them to connect to Wi-Fi, but the smartthings home automation features will not see them. They are not a compatible device.

If you are trying to control them with the home automation features, there may be a workaround. See the FAQ (this is a clickable link)


(Dai Croke) #3

Thanks for the quick reply,

I’m a bit confused, I don’t have a hub I was under the impression that these would work with an Amazon Echo and didn’t need a hub.

This is how they were described by Amazon:
“TECKIN WiFi Smart Plug, Mini Outlet Smart Socket, Energy Monitoring, Timing Function Control Your Devices from Anywhere, Works with Amazon Alexa and Google, No Hub Required(4 Pack)”


#4

This forum is for people who are using the Samsung smartthings home automation platform. So all of the answers that you will get will be within the context of that platform.

It’s a very active forum, so it does tend to come up near the top in general google home automation searches, but it is specific to the Samsung platform.

Since you aren’t using that, your best bet is to check with Amazon support. They’re generally very good about this kind of stuff if you bought the product from them. Use the “contact us“ button on the left side of the screen:

One common problem that does come up with these devices is that your phone that has the device app will have to be on the same network as the device when you set it up. A lot of android phones automatically switch to the 5.0 network even if you select the 2.4, so that might be the problem.


(Dai Croke) #5

Ok mate thanks for you help.