Syncing Xbox One (and probably anyother console) and Harmony

core
harmony

(Daniel Pena) #1

I thought I’d share a problem that I had in my house hold and how I fixed it, if any one turned on the XB1 via the controller, inserting a DVD/game or w/ ‘Hey Cortana, Turn on’ my light routines wouldn’t run because Harmony never knew the Xbox was on. Also it was just annoying on for other routines.

So I used the smart things plug w/ the XBOX plugged into it and CoRE, then made a rule that turned on the ‘Turn on XBOX’ routine via smarttings when power was raised above 70w and Turn off the routine when power drops below 30W. It’s worked good for about 2 weeks now with no intermittent power ons.


(Realy Living Dream) #2

Cool idea/ solution. Xbox is plugged into Aotec power strip, so would be easy enough to do.
I just got in the habit of having Alexa turn on the Xbox. That way everything stayed in sync


(Ron Talley) #3

I had the same problem! Wasn’t me but the kids refusing to talk to Alexa.

I took a different approach that didn’t cost me a smart plug. I used an app called Host Pinger. Since I have a Pi 3 that is always on, whenever the XB1 is on/off, the Host Pinger app would report that in ST via a Virtual Switch. I then use that switch to do the same as you did above.


#4

Great idea! Have you ever had problems with the xbox triggering the routine when it does its background updates? I feel like my xbox is constantly downloading and installing updates while its “off”. I know this is a feature that can be disabled on the xbox but its nice to have.


(Ron Talley) #5

You know what, you might have just solved a mystery for me! There have been times late at night where I would get a notification that the XBox will turn off in 10 minutes (CoRE rule if no motion for 1hr then send push, wait 10 minutes, turn off).

I just chalked it up to the kids leaving the dang thing on. Hmmm LMAO!


(Daniel Pena) #6

Not in 3 weeks, I monitored the power while off and downloading a game and it never hit above 70W, so that’s why I put it at 70W for on and it still drops below 30W when I turn it off then climbs to around 50W while it downloads. There have been updates also and no random start ups. I also had the piston SMS me if it turned on or off while I was home for the 2 week test period and it never did so I have since removed it.


(Daniel Pena) #7

Well I had an update on my XB last night that spiked at 75W and turned everything on, I bumped up the “turn on” limit to 76W and it works, I’ll wait and see if another update triggers anything on.


(Mike) #8

i know this is an old thread guys but could you elaborate on why, what and how you achieved Xbox integration with CoRE

i understand the basics but why ON above 75w and why OFF below 30w, my xbox is on 24/7 which is a shame as i would love it to sleep properly and on sleep shut down TV AND sat box connected to Kinnect

I have always assumed switching OFF at plug would be a bad thing, saying to Echo Xbox on and have xbox fire up and bring with it the other bits of kit would be very handy

and before anyone says just use kinnect to do it… Kinnect is terrible for voice and in my house no matter what i do unless you shout at Kinnect it fails to work, Echo is a much better voice listening device in my situation


#9

There is a setting on the Xbox to disable standby mode that should give you cleaner on/off status with power monitoring, but you don’t get automatic updates so pick your poison


(Daniel Pena) #10

The plug is only used for monitoring power usage and never to turn off/on the console. This is for syncing the console state with a Logitech Harmony activity if turned on via the Kinect, Controller…ect.

Here’s the webCoRE piston, Switch 2 is the Harmony activity. And wattage is per an original XBOX One.


(Mike) #11

got ya , sorry hadnt realised it was using the harmony as well, if only MS would wake up and get on board with everyone else who is passing them at at speed