Switch Z-wave Yale Deadbolt from CPI Security to Smartthings?

I recently moved into a home with CPI Security and installed CPI devices that work off a modified alarm.com/2gig ecosystem. I unsubscribed from CPI but they left behind a Yale YRD120 z-wave deadbolt, and I am trying to add it to my new Smartthings network. I’ve located the device manual and tried to pair it but it won’t add to network like it should per the manual. It functioned just fine in the CPI system.

Does anyone know if the deadbolts used with CPI have a different firmware that precludes it from working in a standard z-wave ecosystem? If so, can this be changed, or am I stuck with buying another deadbolt if I want to integrate it with smartthings?

Thank you in advance for your help.

Try this:

  1. Reset your lock to factory defaults
  2. Reboot your hub
  3. Bring your lock within 5ft of the hub
  4. Exclude your lock
  5. Pair your lock

It should work if it’s a Z-Wave lock. You can optionally use this enhanced lock device handler to get access to your locks’ advanced feature.

Thanks for your input, RBoy. I tried those steps, however the issue remains that the lock will not allow me to pair with a new network.

Your device handler looks pretty sweet but not sure that will help if I can’t get it paired to the hub in the first place.

Have the same exact issue. Any chance you figured it out? I have the Yale 120dr and coolant connect to my ring network…

Some hubs enable the anti theft feature while pairing. That means you’ll have to exclude that lock from the original system to disable anti theft before it can be paired with another hub. Not sure if you’re running into this setup.