Support Needed - Hello World Edge Driver

I’m trying to get a “Hello World” edge driver working.

I’ve successfully:

  1. Created a channel
  2. Uploaded my “Hello World” Driver Package
  3. Assigned/Published the driver to the channel

But I get the following error when trying to enrol my hub onto the channel using the CLI command
smartthings edge:channels:enroll

Error: Request failed with status code 403: {“requestId”:“4243315E-00D4-4FAA-BB3D-02B8CF02E9EF”,“error”:{“code”:“ForbiddenError”,“message”:“Forbidden”,“details”:}}
when enrolling my Hub onto the channel.
It prompted me for the channel and for my Hub. but then threw the 403 error.

Help Please.

Nb. I am running CLI version 28
Nb. I have generated a brand new PAT token with all permissions but no luck.
Nb. I am a UK customer
Nb. My Hub is a hub v2, UK customer
Nb. It is running firmware version 000.038.00010

Hi @Tim99, since you mention a PAT, I assume you have configured your CLI using a PAT in config.yaml? It might be worth seeing if disabling that and using the token provided via the default OAuth flow resolves the problem, at least for now. The token acquired via that flow should have all required scopes.

The other thing to check on is to ensure that the account the hub is associated with is the same as the one being used for development. If they are not on the same account, driver sharing would need to be used to enroll the hub in the channel and make it available for install.

There could also be some issue on our end as we are in beta but determining if this is a PAT token vs one acquired via the default login flow would be helpful information.


@posborne you are a star! I deleted the config.yaml file which had the reference to the PAT token in it and reran the enrol CLI command. it took me to the security screen and the enrol now works!
Thanks very much.
I guess the Hub permissions need to be added to the PAT Token generation process.


Glad that worked @Tim99, I’ll follow up with the team to ensure that all the required scopes are available on the PAT page. They have been in my testing, but there could be a configuration flag that is still gating some of them for external users.