Sunset to Sunrise Automation in New SmartThings app not working

same issue here - have smartlighting installed, have weather station, have updated both; sunset and sunrise times are accurate in IDE, but the automations fire at the same time every day, the time of sunset and sunrise on the day I created or updated the automation. New, not Classic app. Smartthings please help

I am a little fuzzy on the details, but it seems the Automations allow the Sunrise and Sunset times to drift a little before they get rescheduled, and that rescheduling isn’t happening. It is being worked on.

Saving the Automation again will reset Sunrise and Sunset to today’s values. Adding a space on the end of the name works particular well as it allows the Automation to be saved but the space is actually removed.

1 Like

Here’s the response that I received from Smartthings Support. Their response was very quick, just a few hours. I tried their solution, but it didn’t work so I created a scene for what I needed to do and then used SmartLighting in SmartApps to trigger the scene. That has been working, but I’ll need about a week to see if the sunrise and sunset times actually change. My guess is that there is a bug in Automations affecting Sunrise and Sunset and their support team needs to hear about this problem from as many people as possible so they can take action and fix the bug. Please let me know if you try this and if it does work for you. Tapan assured me that uninstalling and reinstalling the app will create no loss of any settings or data:

Thanks for contacting Samsung SmartThings Support.

We’re sorry to know about the difficulties you’re experiencing. We’ll right away investigate the issue.

As far as your query is concerned I suggest, please reset the geolocation once as per the below steps:

1. From the Home screen, tap on More Options (3 vertical dots)
2. Tap on Manage Location > Tap Geolocation
3. Tap the map (if needed, long press to place the pin in a new spot on the map, or tap and hold the pin to drag it)
4. Pinch and zoom to change the size of the geofence surrounding your home (place your location to a different time zone other than your correct location)
5. Tap Done when you’re done and save the location
6. Wait some time and set it back to your accurate location following the same above steps

If the issue persists, kindly re-install the SmartThings app along with rebooting your phone and check with the result.

If you continue to face the challenges, kindly help me with the below details:

*** Attach a screen record or screenshots while facing the issue**
*** SmartThings app version and your mobile details (brand, model, OS version)**

I look forward to hearing from you.

Regards,
Tapan
Samsung SmartThings Support.
www.smartthings.com

1 Like

Uninstalling and reinstalling the app will reset your dashboard, just FYI.

Good to know. Now, I’m happy I didn’t actually uninstall and reinstall. Thanks very much!

1 Like

Just to add to this thread I am having same issue for last few days, lights do turn on at Sunset, but they do not turn off at Sunrise. Re-saving the automation does not help, it seem. Patiently waiting for the fix :slight_smile:

Similar issue here.

Automations triggered by sunrise and sunset are happening at the same minute each day, not updating.

I have neither SmartLighting or WeatherStation.
IDE is showing correct sunrise and sunset times.
But hub is not turning lights on and off at the sun times showing in the IDE.

To add insult to injury, Smart Lighting automations have stopped working today. It is throwing the error “We’re having trouble connecting. Check your network connection and try again” in the ST app, when you try to add/edit a lighting automation. I have two Locations that are experiencing the same issue.

I can confirm I have the same issue. Sunset and sunrise occur the same time. Also history is not updating on my app. These issues arose since I upgraded to latest firmware

I’m having the same issue stated above. I’ve manually installed the weather station app and it shows the correct sunrise/sunset, but when I go into IDE and check the location, it shows the sunrise/sunset over an hour and ten minutes off (basically from almost a month ago). I tried changing the geolocation to something different multiple times and changing it back and still no joy.

I’ve been having the same issue for a little while. The IDE shows the correct time for sunrise and sunset but the automations don’t execute at the correct time. I’m going to try re-saving them to see if that helps (at least temporarily) but a permanent fix for this would be really nice. I have automations that turn lights on/off and open/closes blinds and it’s pretty annoying that my blinds close about 45 minutes before sunset right now!

I got this message as well after android updated on my phone. Couldn’t figure out what was going on and I consistently got the message. Didn’t immediately make the connection, then I realized android added Smartthings shortcuts in the Android Settings bar. Being a little suspicious of what that was doing, I disabled it, and lo and behold I no longer got the error message when trying to access Smart Lighting.

Also, in regards to the sunrise/sunset automations. . . the ability to trigger regular Automations with Sunrise/Sunset is definitely broken. By regular I mean the automations in main SmartThings menu. It does not matter whether your IDE shows the right times, whether your geolocation is updated, whether you have installed the Smartweather Tile, or whether you update weather station or Smartlighting in the IDE. Nothing changed the fact for me that sunrise/sunset were frozen in time as of the time I created or updated the automation.

However the sunset and sunrise triggers DO work if you set them up as SmartLighting Automations under the Smartlighting SmartApp (as opposed to regular automations defined above. Go into SmartApps, make sure SmartLighting is installed, and then go into SmartLighting to create an automation). SmartLighting Automations must have their very own logic. The only downside to setting up the automation here is that the capabilities are a little limited - for instance you can’t do multi-trigger automations, and there may be some devices you cannot control. You may need to set up some virtual switches to accomplish something complex. But it works. Now if only they didn’t create two places to see my automations. . .

@rcl767 when did that happen? if SmartLighting wasn’t working a week ago, on or about 2/24, that’s when everyone was having an issue. Are you using Android 10 or 11? I’m on 11 for about a month (Galaxy S20)

Not sure where those are. If you mean the bar when you swipe down from the top, I don’t see anything on my phone.

My System Update History shows updated last Feb 23, 2021. It shows “Software Updated to G950USQU8DUA2”. That said, I am on a Samsung Galaxy S8 on Verizon (call me phone-loyal), and shows Android Version 9.

I believe the shortcuts I am referring to are officially called the “SmartThings Panel”, which you can turn on in the Settings screen on the SmartThings App. I don’t know why or how, but as soon as I turned off the SmartThings Panel I no longer got the error message when I tried to do anything with the automations in the SmartLighting app.

Well, if you’re feeling courageous, turn it back on and see what happens, but I really think it is coincidental. I don’t have any more Android 9, so can’t try it myself. But I know what panel you’re referring to, the little ribbon of ST icons (personally never found it useful anyway).

Against my better judgement I went ahead and turned on the smartthings panel and fortunately did not get the connection error in smartlighting that I did before. Even more fortunately I turned off the smartthings panel again and everything still seems to work, so curiosity did not kill this cat. You are correct in that it may have been a coincidence but that action is the only thing I did between the time smartlighting failed and worked. Who knows, it’s an option for others to try if they are stymied.

1 Like