Sunset to Sunrise Automation in New SmartThings app not working

Let me preface this with I did perform a search beforehand on this and while there were several discussions about this I did not find a resolution that I could accomplish on my own.

I have the NEW SmartThings Android app. I have hub V2.

All I am trying to do is turn my driveway lights on at sunset and off at sunrise.
Does anyone have any idea why these automations would not work? I’ve tried setting this up via Automations and via the Smart lighting SmartApp and neither will work.

@Brad_ST I know you have helped a lot of folks with this. Any ideas?

1 Like

Try Smart Lighting

2 Likes

I did. That’s what the 4th picture in the above screenshots show. That did not work either.

1 Like

Sunset times are determined in your cloud account and at least it used to be true that if you created a new rule it wouldn’t take affect until the next day. So if you created a rule Tuesday morning at 10 AM to turn a light on at sunset each night the first time that rule would run would be on Wednesday.

I don’t know if that’s still true or if that’s what you run into, but in the past we have seen community members who would create a rule, it wouldn’t fire, so they would change something in it, in effect creating a new rule and they were always one day behind when it would actually work. It could be very frustrating. :disappointed_relieved:

I’m not sure, but I believe you can still look in the IDE and see when the rule is scheduled to run next.

Also, just to get this out-of-the-way… Again, it used to be true that sunrise and sunset rules could only run in the cloud not locally. So you had to have live Internet access at the time they’re scheduled to fire or it wouldn’t happen.

(Sorry I’m so out of date on this stuff, the V3 app only recently became voice navigable and I’m just not familiar with it yet.)

I have been unable to test it but with me I was told it was because I did not have the Hello Home and Weather Station installed. I was told to get this installed I had to log a case with support but I discovered if you login with the classic app it installs them automatically. Unfortunately just after I did this my lights all stopped working, so I could not test.
Check if you have them installed and if not install them (install classic app, login with it, and see if they are installed in the IDE).
In the IDE, look at:

Locations>Installed SmartApps>Smartapps(a clickable link)

to see if installed or not.

@srastegarlari, Confirm that your location has been set correctly in the app. Check in the IDE do you see sunrise and sunset values and you have got the right time zone too.

You can test it in the app, by adding offsets of hours. Like during daylight hours set an event for sunset -X hours. That will trigger the automation at your time if you set correctly X. You need to pass the daylight/night time (sunrise/sunset) to trigger it.

Are things working now? The logs indicate Exterior Driveway Light was turned on at sunset tonight as expected due to your automation.

2 Likes

In my case, I had to disable automatic date and hour. Otherwise, automation was being executed 1 hour later.

This configuration is relevant just at the moment of adding automation. Once added, I may reactivate automatic date and hour.

My timezone is -03:00 GMT Brasilia Time.
This timezone used to have Daylight Saving Time (DST) in the end of the year, but now it isn’t affected by DST anymore.
I manually changed it to -03:00 GMT Recife Time.

1 Like

Thank you everyone for the help and suggestions. @Brad_ST , yes, things are working now. I see that you added Hello Home to my SmartApps which in turn activated the sunrise and sunset variables in the IDE. That did the trick! Thank you so much!

I’m adding images of what the HelloHome SmartApp and the Sunrise and Sunset parameters look like so newer folks know what to look for if they run into the same challenge.

Sunr to Suns

I think I’m having a similar problem I have a Smarthings V2 Hub, a Samsung Door Sensor, and I want the lights to turn on when I open the door, but only between sunset>sunrise (at night time basically). But it seems they turn on all the time, despite my settings in the Smartlighting app. I’m using the v1.6.42-350 of the SmartThings app on iOS 13

I see that you installed Hello Home, which then meant that the hub cited the sunrise and sunset times - I can’t seem to do this. When I look at ‘add one’ under SmartApps, I’m don’t see this as an option.

Any advice?

Try to do it through Automations.

I got Hello Home and Weather Station installed by installing and logging into the classic app. Then I uninstalled the classic app and continued to use the new one. Hello Home and Weather Station remained installed in the IDE.
For some reason they install with classic app but not with the new one.

Thanks all! I noticed in the thread that the admin was able to add this as well. @Brad_ST is this something that could be done for me as well?

Tried the automation I built today, and it seems to be working! Thanks for the idea. It’s not as seamless as the smart lights, as I the ‘what to do when the door closes’ part isn’t just a toggle switch like it does in the smartlights app, but it’s working during the right times now

1 Like

Tried this past weekend. Our automation restrictions are sunset to sunrise, but the automation runs 24 hours. AFAIK I have latest production updates on the hub.

@SpeedyK2000 @ScottClark I installed Hello Home for both of you. Your sunrise/sunset automations should work now.

I thought I was the only one having this problem. LOL I will swap out the Smart Lighting process and try automatons.

Brad, can I get Hello Home installed? How does that occur?

Added it back.

@Brad_ST Do I need same magic from you to have the automation working? How this can be achieved?