Sunrise and sunset time stuck

When I log into the IDE, the sunrise and sunset times have bee stuck at 6:50 AM and 4:54 PM for last more than a week. The actual sunrise and sunset at my location are 7:10 AM and 4:43 PM. The location of hub (lat and long) are correct. I had opened a support ticket with ST support more than a week ago, but never got any response. These incorrect timings are causing the sunrise and sunset automations to run at incorrect times. I have restarted the hub by pulling out power and batteries, but no change. How to fix this?


One of the ways I was able to fix sunrise/sunset is to change the location of one of the hubs to say another time zone in the app just pick a random location and then set the hub back to the original location.

Also have you tried to contact SmartThings support?

Sometimes the cloud Weather Station app gets stuck and doesn’t update the times.

  1. Login to the online IDE:
  2. Click My Locations and click into your location
  3. Scroll down and click List SmartApps
  4. Under Hello Home at the top you will find one called Weather Station, click the Update link to the right

If you click into Weather Station that will show you the times that were downloaded and next action time.

1 Like

I did open a support ticket more than a week ago, but heard nothing back.

Wow…!! The Weather Station update did the trick. Thank you so much…!!

In the job history, the last update was on 12th of November. Is there a way to create some kind of piston in WebCore or an automation in ST to update this periodically?

1 Like

Check out this topic to automatically update the weather stations and fix a few other bugs:

I have lifetime subscription to your apps. I have installed the app. Do I need to do any configuration? When I select this app in ST to add to my smart apps, I see the following screen. If I press the Save option, it just gives an error that I need to fill all required fields.

Looks like you’re using a custom weather device, you need to use the stock built in ST weather device type for the app to work.

Is there a way to find out what custom weather device exists? As far as I can tell, I am not using any custom weather app/DTH.


Did you install the SmartWeather Device? See the same page link for instructions on how to do it or from our website at SmartApp No 20, quoting:

a.Install the Smart Weather Tile Device from the Web Ide as detailed below
Login to
Click on “My Devices”
Click “+New Device” button in top right corner
Type in “Weather Station” in the “Name”
Type in “FFC” in the “Device Network Id”
Under “Type *”, select “SmartWeather Station Tile”
Under “Location”, select your location
Click on “Create” at the bottom of the page

Color me red. I am feeling like an idiot. It worked…Thanks!!!

1 Like