Strange problem with Alexa Routines

I have a routine called Family room and it activates two devices. Device one is a GE Z-Wave Dimmer and device two is an IRIS smart plug. When I say “Alexa Family Room” it turns on the two devices then the IRIS turns off. I have no idea why. I also tried using virtual switch which activates the two devices via Ask Alexa and the same thing happens.

Goto the Iris Plug tile in the SmartThings app. Then goto the Recent tab. There, you should be able to see what turned off the Iris Plug. You can then goto the SmartApp tab and fix the SmartApp (Rule) that is turning the Plug off.

1 Like

Nothing in there, hoping it was that Alex bug reported yesterday.

Are you sure that in the Alexa App itselft, when you select the Control Device (Iris Smart Plug) you do not have the state as off?

positive, as the only thing the Alexa app controlls is a vertural switch.

Wh Could you post a screen shot? From your original post, it reads as if you had two physical devices in the Alexa routine…

There has to be something in the logs or IDE that is showing what turned off the Iris Plug which would be in your recent events tab in the ST App.

What happens when you turn on the Iris Plug by itself? Does it turn back off?

The way I have it set up, is Alexa Routine has a virtual momentary switch. When taped it activates a Ask Alex Macro with the two other devices. I checked logs and Ask Alexa is sending the on command for both, but there is nothing in the IRIS live logging showing the off command, but yet it is off. It goes on for a second then off. But if I call the IRIS by itself it works. I am very confused.

Yeah, I agree, that makes no sense. You have two native ways of doing this:

Use a regular SmartThings routine.
Use a regular Alexa routine.

If using a virtual switch, I would use webCoRE.

One last question, in the Iris Plug ST SmartApp tab, there should be a listed of SmartApps or rules that are connected to that Plug. At least it should be, Ask Alexa and Alexa…The original Routine should be listed here as well…There is more than likely a rule that you have created that is executing…

Below are SS of what all is tied to the Smart Plug that controls my Iron. Anyone of the Apps or Rules can trigger it. To know which one, I go to the recent tab and it will tell me what did what. You can get a better picture looking at the log in the IDE but for the most part, these two tabs tell a pretty good story.

Try posting the following:


Yes I see it and it is correct, I tried WebCoRE and the delay was just horrible to say the least. I can try it again, but not sure if it will work. Ok just tried it again three times and it works perfectly, so another GHOST in my system. I am going to call Ghost Busters. Thanks for the support.

1 Like

Alexa has lost her complete mind as of late…:man_shrugging:t5::scream::rofl:

That is a fact, I am not sure if it is Alexa, or SmartThings integration.

You said you have a virtual switch involved in this. Is it a virtual momentary button tile? If you have something else which has the outlet set up to follow the virtual switch and the virtual switch is turning on and then off then obviously the outlet will turn on and then off. The outlet itself wouldn’t show the problem because the issue is the virtual switch.

If you just turn the virtual switch on in the app does the outlet come on and go off again?

And can you post whatever you have set up to cause the outlet to follow the momentary switch?

@JDRoberts Not suren what you are referring to. I have the virtual momentary button controls a macro in Ask Alexa. So even if I disable the Macro the problem exists if I do it using a sudo name in Alexa. In the Macro are the two dimmers. It is only the lamp that causes this problem. I don’t know where to look.