Stelpro releases the first Z-Wave Plus Line-Voltage thermostat: the STZW402+ Stelpro Ki Thermostat

Can anyone point me to good advice on how to install this thermostat on a double pole installation?

I’ve installed 2 of these thermostats at a prior condo, but my new condo has double pole installation and its confusing me a bit.

First attempt ended in a blown thermostat. A bit scary, but everyone is safe.

Second attempt at install was somewhat successful. It didn’t blow up, the baseboard heater begin to blow, but the screen on the thermostat wouldn’t light up at all.

I followed this wiring diagram:

FireShot Capture 029 -  - pro.stelpro.com

As the weather is transitioning into spring, this isn’t a major priority right now. I also have a Daikin mini split which I will be using the majority of the time, but going forward I would like to update old Cadet thermostats.

The wiring diagram you shown is correct.
However, this line voltage thermostat is not intented for double pole installation since the thermostat is always powered on.

NOTE: I recommend that you call out for a professional electrician for the electrical wiring.

1 Like

A new update to the device controller in the new ST app appears to have disabled the ability to control the heat. Anyone else seeing this? I have 4 of these installed in a remote property 200 miles away so control over the set point is essential.

2 Likes

I am seeing the same thing here with my Orleans convectors, the adjustment buttons are missing!. Also, on a separate note (but possibly related) my Sensibo has no adjustment buttons.

1 Like

I have the same problem … As a temporary solution my “scenes” are still working to change the temperature so you might want to use that @clifster ?

Thanks @Keysheng. I still have the Classic ST app and integration is partially configured with Alexa. Both of those, ironically, continue to work just fine for manually adjusting temperature/settings. It’s just the modern first party app that’s failed.

1 Like

Exactly the same scenario for me - the new app shows the same as Clifster i.e. no ability to change temp. I still have the old app installed and that continues to let me change but as we know that’s end of life. The scene option is good to know thanks. Need basic functionality back

ST team are on top of this it seems see this other discussion here on same issue

A new update in the ST app appears to have disabled the ability to control the heat. I have 6 of these installed in a remote property so control over the set point is essential. Anybody have an update on what to do here. I was at my property over the weekend and tried r syncing them to the hub and no change.

Day 10 still no temperature adjustment, tickets logged with support regarding this issue and not one response at all. Not even a note to say they are working on it. :neutral_face:

From what I read, the old SmartThings classic app is still working…
Other people reported that the deprecated custom device handler from the Stelpro GitHub could still do the trick.
However, be aware that there is no ongoing support on these custom device handlers.
On some other thread, some SmartThings rep stated that this is a known issue and they are working on it.

1 Like

It has been fixed with the last update of the smart things app :slightly_smiling_face:

Yep! Mine is working well too now.

Hi Folks,

Just curious, it appears my heaters, Stelpro Orleans (with built in Ki Thermostats) are polling every minute. I currently have 5 of these but that will be going to 11 once my house renos are completed. Should I be concerned with the zwave network load on the hub with all of this reporting going on continuously?

Thanks
Chad

Hi Chad,

The Stelpro Orleans heaters, if they have built-in thermostat, would be zigbee thermostat.
The Stelpro Ki Z-Wave thermostat (First Generation) were communicating a lot.
This was changed in the next generation.

Hi gouroufui, thaks for the response! Yes, they are Zigbee thermostats and they are communicating each minute. These are brand new heaters so I suspect it should be the most current generation, is this normal?

Hi,
The zigbee thermostat don’t send anything on their own unless they are told to do so.
For instance, if this thermostat is reporting its temperature every minute, it is because the SmartThings hub sent configuration report commands to the thermostat to order it to report the temperature at that frequency.

I do not foresee any issue with that (zigbee communication frequency).

What I was refencing with the First Gen of Z-Wave was about the operating state sent about every 15 seconds. This was changed on the z-wave.

Thanks gouroufui! that makes perfect sense. Is there a way to adjust this? If it doesn’t affect the system then no worries eh?

Unless you write your own device handler for the thermostat, SmartThings handles it internally.
But I wouln’t worry about that.

1 Like

I’m experiencing the same thing with my Stelpro thermostats. Temperature adjustment worked 2 days ago. My webcore automations appear to still be working. Just cannot change the temperature of my thermostats using the app. Is there an old device handler that we can use until this is fixed?