ST Power Socket - reset / stopped working

So, I wanted to move my UK ST power socket from my V2 hub to my V1 hub.
I removed it using the app, and then tried to add it to my V1 hub.
However, the device doesnt get found.
There are no UK instructions for factory resetting the socket, so followed the US version - hold the button on while plugging/switching on until blue LED lit.

I still couldnt add it in, nor could I add it back to the V2 hub.

I saw a few posts that people were having problems (out of the box) - what did those of you do who contacted support - was there a different reset method? Or did you get a replacement socket?

hi @Andy_Godber - my ST power socket has been playing up, an email to resulted in a replacement process.

unfortunately, the amazing support experience from the SmartThings staffers is marred by Samsung UK outsourcing the RMA process to a third party, that does as little to make it a good experience as they can (no replacement until you send the original back, 2nd class postage and they have agreed you aren’t lying!)

Anyway, should be sending mine away today, hoping they can turn it around pretty quickly!


Don’t get too hopeful. I went through the returns process last week, sent mine off on Tuesday, Friday I got an email from Samsung with a DPD delivery which arrived on Saturday.

Opened the box and tried the plug. Still faulty, I then realized the plug was packaged exactly as I’d sent it… I don’t think they RMA company even opened the box. I suspect they just put their own tape and a label on and sent it back.

Sending a polite email tomorrow and will not be returning the faulty plug until they send me a working one first. I’m on the insiders trial so not really able to do any tasks until I can actually do something when a sensor is triggered except send me a notification at the moment.

I’m also an insider triallist, eager to start documenting my experiences but currently those experiences are a bit marred!

Need to to drop mine in the post today, let’s see what happens with it.


Email sent yesterday morning to both support and Digicare… No response so far as to why I was returned the same faulty plug I sent them. Will be sending a chase tomorrow