ST Multisensor Transition Issues with Tilt Detection

Some members have reported that after transitioning to an edge driver, these devices needed to have the initial xyz values reset depending on what they had been at the time of the transition. This would explain why you could have two identical devices and one was reporting accelerometer values (tilt or vibration) while another was reporting only open/close. I’m not sure what the resolution was, though.

@Mariano_Colmenarejo @jkp @nayelyz

I think you misunderstood. The 2 devices that are working fine with Mariano’s driver are identical, and they are the older Smart Sense ones. True, I had to figure out which axis to set them at to get them to work properly. The one that does not work is the newer Aeotec one. Mariano replied just prior to you and has 3 and they work well. So I don’t know why mine does not.


Apologies if I wasn’t clear. Regardless of generation, if the open/close sensor works and the tilt/vibration reports do not, the issue is with the accelerometer inside the device.

Mariano has said that the process sometimes leaves the preference value set to know, which then causes the accelerometer not to get set up.

So resetting the preferences will often solve the problem for that particular device. He gives the details for how to do this in a post below.

Edge drivers, even with brand new devices, seem particularly prone to needing this step. . This is why it might work for one person while an identical model did not work for another. Different initial values.


could You change to zigbee Thing Mc to see al data if device?

Could there be a difference in the fingerprints?

any change in model or manufacturer means that specific subdrivers for each model are not executed.

Also, I have reported that the preferences default are null during new installation, if this is happening the acceleration cluster will not be configures and will give one error.

Go into preferences and change one a one all the values to another, the closest to the default value. It has to be different for it to be reported and saved.

Once this is done, change to another driver, zigbee thing Mc, for example, and then go back to the Zigbee Contact Mc driver.

If this is the problem, it should work.

If it works, I would appreciate a pairing log of a device from scratch to see the error and send it to smartthings

1 Like

Since they only appear as placeholder in the IDE, how do I do that? I’m guessing some CLI command or something?

See the “Life after the IDE” thread: there are several ways.

Before I change anything, I want to check something with you. I just noticed that when I go to the driver list in my hub, and touch on the Mariano shared beta driver box, log in to SmartThings, and then go to your available drivers, I don’t have anything installed. Yet this is the screen shot of the driver that is installed.

Have I got an outdated driver? If so, is it the Zigbee Multi Sensor Mc I should install?

The one you have is old, but it could work, it doesn’t have an X,Y,Z axis change

If you want to use my driver you must install the Zigbee Contact Mc for all multipurpose and normal sensors

If you want to use the stock you must install the Zigbee Contact for all the multipurpose and normal sensors

You should then uninstall the old one.

The old driver does have an X,Y,Z axis change. That’s how it is working with my other 2 multipurpose sensors, set to the Y axis instead of the default Z axis.

I already have the stock Zigbee Contact installed. When I tried the Aeotec sensor with it, it didn’t show any axis changes either.

I will install your Zigbee Contact Mc and write back.

Update 1: That was it. The Zigbee Contact Mc works. Now I have to test it with my other multisensors

Update 2: The older multisensors work fine also. I will delete the older Multipurpose Sensor Mc driver.

Thanks very much for your help!

Is it possible that some other peoples difficulties could simply be an outdated driver? I only loaded your driver couple of months ago.


I don’t know how to reset the XYZ values other than by changing the selected axis. Regardless, the point is moot now as you can see from the conversation with Mariano. Looks like I had an older version of his driver. The newer one resolved the problem.

Thanks very much for your help!

1 Like

I’m glad it works!!

Did you make any changes to the preferences values before switching to the Zigbee Contact Mc driver?

It could be related to the problem reported about defual values.

These drivers have sensitivity and axis customization and therefore use the default value of the preference during installation, if that value is erroneously null, the acceleration cluster configuration is not carried out and does not work.

The stock zigbee Contact driver uses fixed values and shouldn’t have that problem.

1 Like

The only changes I made were done when I first installed the Zigbee Contact Mc driver for the Aeotec sensor. Those changes were to turn on garage door, and set the Y axis instead of the default Z axis. When I switched the older sensors over to this driver, they used the same settings as the Aeotec sensor, so they were already set to garage mode and Y axis.


I have 2 Multi sensors that are from the Kickstarter version 1. I read through this thread. I don’t have the option to use as Garage in the settings. There is only a temp offset setting. Are these able to be updated for using as a garage tilt sensor again? the XYZ values will change when the door is open/closed. I have no way to automate the Open/Closed value though. Thanks!

Hi @ericsims please can you give me more information about your device (model, name in the app)?, enable support access to the investigated and if you know the fingerprint of your device can help us.

Enable support access to your account:

  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

I sent you a direct message. Thanks!

Hi @ericsims after checking your device, the reason you can’t see the option is that the device profile of your device you are using, only has the preference tempOffset, do you remember if you had this functionality before, or do you remember the DTH of your device?

I was able to get these devices to function as Garage door tilt sensors by selecting the device type in the old SmartThings graph as SmartSense Multi Garage.

I understand, Do you remember the DTH of your device?

These were the steps to get this to function in the past. There were no settings to change on the device itself in the SmartThings App.

  1. At web address: I clicked on my Garage Door Sensor.
  2. At the bottom of the web page displayed: click Edit
  3. Click on the pull down menu in the ‘Type’ box (5th box down)
  4. Choose: “SmartSense Garage Door Multi” from the list of choices.
  5. Click Update at the bottom of the Edit Device page.

Excuse me jumping in here, but isn’t that a bug? The devices that use the smartsense-multi profile also use the smartsense-multi sub-driver and that tests the certifiedpreferences.garageSensor preference which isn’t in the profile.

local function contact_handler(device, value)
  local event
  if not device.preferences["certifiedpreferences.garageSensor"] then
1 Like