ST & Linear’s GD00Z-1 Z-Wave garage door controller

done:

Thanks Gary! This is great.

Before I purchase a Linear GD00Z or the Iris garage door controller I need a few answers from an expert:

Are these two items exactly the same ?
Is this setup fully functional?

Thanks!!

Yes. It is exactly the same. But you can get GD00Z for less money from Amazon. And I would of think twice before buy this device at all. Seems to me that Z-way switch plus on/off sensor can do a better job. The problem with GDZ000 that after power loss it goes into unknown state and you will have to open a close garage door to reset status. So you definitely need to use some sort of UPS with GD00Z.

@Kooltaco I agree with murzik. I’ve done some research on the linear gd004 all in one garage controllers and they really are not fully compatible(at least without addition of device type custom made for it), thus i went for a relay + orientation sensor (such as ST multi or Ecolink tilt) because this setup is fully supported by ST. I even emailed ST support because i was concerned that eventually the native setup of relay + orientation sensor would be tossed for the all in one Garage controllers like linear GD004 and my response from ST described that the relay + orientation sensor setup is not going away at all, and they are working on providing official support for garage controllers like Linear GD004. My setup consists of 3 garage doors, each door has 1 ecolink tilt sensor and 1 mimolite relay sensor and this setup has worked wonderfully.

Here’s a custom device type for the GD00Z-4 which provides support for some of the missing features:

Does your device type solves issue with “unknown” state after device loses power?

It works here in our labs but one needs to either manually “refresh it” or wait for a while to refresh itself. It isn’t instantaneous as that’s the way the device is built.
Key points to note:

  1. Make sure the sensor is working (we had some trouble with the alignment, it was at a slight angle when mounting to at first we couldn’t get it “recognize”). After fixing the mounting angle it detected the position
  2. After a power failure you need to force the unit to reset/resync itself with the sensor. Two way, hit refresh and it can take about 5 minutes to complete the syncing process or wait for about 15 minutes and it’ll refresh itself over time

Hi Gary,
I am trying to pair Linear GD00Z-1 with ST. I used your code and created a new Device type.
I tried creating a device from IDE and used the new device type, it showed up under Things on my phone but with Unknown status.
Here’s what I have done so far -

  1. Installed sensor on the door as per the instructions
  2. Connected the controller to Garage door opener’s Pushbutton and Common terminals
  3. Powered up the controller
    5)Reset the controller.
  4. Implemented New device type (from your code)

I also, tried your suggestion of trying to add the device from “Door & Locks” -Add A door - But I get stuck step where it asks me for sensor and it can’t find a sensor.

I am obviously doing something wrong!

Hiri

I added mine from the Android App just using the Generic Add new device after installing the new device type to the ide using Gary’s code.

On the app…
(+) -> “Connect New Device”

Are you close enough to your hub for include ?
I did this before mounting the device in my garage so I could have it sitting closer than 3 ft from the ST hub. Typically you need to be very close to the hub to add devices. You can of course always bring the hub out to the unit if you have a plug and network connection available ( or really long cables :slight_smile: )

Ensure that the device is using the proper device type.

(OMG, the ide is INCREDIBLY slow right now for me… it’s taking 5+ minutes just to load the “my devices” page!!!)

From the IDE, select “my devices” and check the “Type” column. If it’s not using the device type you added, click the “display name” for the device, “edit”, and change the device type.

If the new device type isn’t showing in the list, you didn’t install the device type properly.

Ron,
So, you are suggesting that I unmount the IRIS controller from Garage door opener, bring it near ST hub, plug it in and then add the device by using the phone app -> (+) -> Connect New Device?
I can try that.

@garyd9 -
From IDE, I deleted the device and created a new device and made sure I selected device type - “My Z-Wave Garage Door Opener” - (your code)
It still shows up on the Phone’s ST app under Things - and shows up as “UNKOWN” and Open and Close links doesn’t work…

Also,In the device property, for the new device I added the “Zigbee Id” and “Device Network Id” are blank. Is this correct?

That was what I had to do. How are you adding it. Are you using “+New Device” from the IDE or adding from the app ? I would add from the mobile app

I think adding from the ide is for devices which are not zwave or zigbee. for example my Solar Panel Monitoring device needed to be added like this because it is a web based interface.

At least that is my understanding. I would listen to @garyd9 advice over mine :smile:

@Ron - I tried both “+New Device” from IDE and also from Mobile App. However, I didn’t try bringing the controller close to ST hub and then try from Mobile app. I will do that tonight.
I will see what advice does @garyd9 has for me and try that as well. Thank you both!

If it connects and gets added then bringing it close will probably not change anything. If it fails connect and get added then it most likely will help it connect if it is closer.

If it does connect and get added do as Gary suggested, open the IDE check your “devices” and make sure the GDZ shows up and is using the correct device type.

That’s NOT what I suggested you do. I didn’t say anything about deleting things. :frowning:

You can’t just add a device from the IDE and have it magically work with ST. Now that you deleted from the IDE, you are going to have to “exclude” the GD00Z.

Okay… You’re going to have to go through the annoying process of excluding the device. I don’t have the app in front of me right now, so I can’t walk you through the steps, but buried in the app is a method for z-wave exclusion. You have to select that, and then tinker with the button on the GD00Z. (I don’t know the sequence off the top of my head.) Once the exclusion is successful, you should re-“include” it.

After you include it again, check in the IDE to see if it’s using the proper device type. If it’s not, then scroll up and read my instructions for changing the device type.

Gary

You can actually still exclude using the “Utilities” in the ide.

My Hubs->View Utilities
Then select “Z-Wave Exclude”

Then click on the include/exclude button on the GD00Z it should now exclude.

The GD00Z will not include until it has been excluded. This is why you should NOT delete devices you have not yet excluded.

@garyd9 -
I found instructions to exclude device and within the app, I was able to exclude and tinker with GD00Z button and excluded the device.
Now, before, I mess up again :smile:,what is the correct way to include the device?
Should I do it in IDE? By clicking on +New Device?
(I don’t think I have any other option anyway - because I tried moving the controller close to ST hub and tried the phone app’s "+ -> Connect New Device - Searching -> Nothing found"
Please let me know my next step

@Ron - Thanks. I learned the hard way :slight_smile:

Now, I need to include the device. I am wondering if I should do it in IDE?