[ST EDGE] Zooz Edge Driver Channel

Thanks, I will hold off doing it with a “z-wave config” driver as I don’t really want to redo 60 routines.

Having same issue with ZEN switch. Worked great until I updated to EDGE Drivers. Every few days it becomes disabled and have to oull the air gap button to restore.

My two Zen20 power strips automatically migrated in the last day or two. They came on board with the stock ZWave switch driver rather than the already installed Zooz Multichannel driver. Channels 2-5 slow up as “edge child” devices in the API browser.

They’re in the kids’ bedrooms and I noticed the change after they were asleep, so I haven’t tried messing with the drivers yet, but all the routines ran correctly at bedtime so I think the stock driver is at least handling basic functionality well. Power meter also seems to show correctly. Will try to find a minute to switch over and experiment more tomorrow.


Hi. Pretty new ST user here and 1st post. :wave:

Just want to add that I am seeing the same issue as RedTx w/ the ZEN32. Any updates? Any information that it would be helpful to have from another user seeing the same behavior?

iOS app v
Hub v3 w/ firmware 000.047.00011
ZEN32 firmware 10.3

@nayelyz is there an update on the iOS multi-component “THEN” issue, it has been broken over 3 months.

Hi, @NickA
The team mentioned this should be solved in the next version of the iOS app, it should come soon, I don’t know the exact date.


Thanks for the update and I look forward to it


Thank you @NickA and @nayelyz!


Confirmed fixed in the iOS version just released.


Curious little issue with a Zen52 recently. I’m not sure where the fault lies, but I figured I’d pop it in here so there was a record.

I have the multirelay set up to control the lights in my garage and outside in the driveway. They’ve been working fine for at least 8 months. The other day I was leaving the house and I noticed the outside lights were on, in the day. I popped into the app and turned them off. When I came home they were on again. I turned them off and checked in the history and saw the two relays have been turning on and off every couple of hours for the past day. Since I had no automations or rules that would turn these on without some kind of interaction I was kind of stumped. I rebooted the hub. They stopped turning on and off on their own, so I thought everything was good.

A day later I was in the API Browser+ and I noticed the two relays were gone. I looked in the app and they were still there and they still worked (I could turn them on and off from the app.) So, no worries, right? Well, the next morning I wake up and, being curious, I check to see if they’re back in the API Browser. Nope, now they gone out of the app too.

The issue was resolved for me too with the latest iOS version of ST.

I’ve started having issues with my ZSE40 4-in-1 sensor (Mfg Code 027A-2021-2101) in the past week or so. This device has been working on this driver since Nov 2022.

It gets stuck in “Motion Detected” and the app history log no longer shows motion as an activity filter. If I remove and reinsert the battery motion starts working and motion activity filter returns for a while. All other aspects of the device are updating properly.

Any idea what may be causing this?

Since the Edge driver update, I’ve had many of my zen27 and zen21 stop responding to physical button presses. They remain responsive through the ST app. Resetting them with the air gap gets the buttons working again, or even tripping the breaker for the circuit they are on.

This has been random and recurring for months. Zooz support didn’t get me anywhere other than just asking for various settings and no solutions. I see this mentioned a few times in the thread. Did anyone get this resolved and how?

Edit: Had a few weeks without issue, then just happened multiple times in the last 3 days.

My 4 in 1 zooz motion sensor is not refreshing battery status. I changed the battery but still stuck at 1%.

Are you on firmware 48.3, that may fix the issue

Yes i am.on 48.3 firmware.

Battery updates can take up to 12 hrs. after installing new batteries.

Ok ill check it in the morning. Thank you.

I have the ZOOZ Edge driver installed and it is working for a number of devices. I have recently tried to add a ZEN76 and the ST hub cannot find it. When I look at the available models, the ZEN76 is not listed. Do I have an old version of the Edge driver? If so, How do I update it? Thank you.

Edge drivers on your hub automatically update within 12 hours of an update being posted. So there is nothing you need to do.

The following is the driver you need if it is not already installed on your hub.