[ST Edge] Z-Wave Plus 700 series based Sensative Strips Sensors Driver [MANUFACTURER VERSION]

This is the Edge driver for Z-Wave Plus 700 series based Sensative Strips Sensors.

It supports all the settings that are relevant to SmartThings and all the features can be used with Automations.


Products supported are Strips Guard 700, Strips Drip 700 and Strips Comfort 700


Strips Guard 700 is a revolutionary magnetic sensor for monitoring of windows, doors, and valuables.

Online manual for Guard 700


  • Contact Sensor
  • Tamper Alert
  • Battery


Strips Drip 700 is ideal for placement anywhere a leak might occur.

Online manual for Drip 700


  • Water Sensor
  • Temperature Sensor
  • Tamper Alert
  • Battery
  • Low/High Temperature Alarm    


Strips Comfort 700 monitors the temperature, ambient light (LUX), and humidity wherever you mount it. With the Strips sliding +Switch button, you can now also manually control lights, ventilation, shades, and other IoT devices in your smart home or apartment.

Online manual for Comfort 700


  • Temperature sensor
  • Humidity sensor
  • Light (LUX) sensor
  • +Switch button (Central Scene Notification)
  • Tamper Alert
  • Battery
  • Low/High Temperature Alarm (Notification Report + Central Scene Notification)
  • Low/High Ambient Light Level Trigger Alert (Central Scene Notification)



Please note that, as of January 2022, Edge is in beta and therefore this driver should also be treated as such.


To install:

Use the following link to enroll in the channel and install the driver on your hub: Channel Invitation.


If your device is already using an Edge driver, you can use the driver utility in the app to switch drivers.


If your device is currently using a Groovy DTH, you will need to remove the device and then add it back to SmartThings to pick up this driver. If you have any custom Groovy DTHs installed that have the device’s fingerprint, either delete the DTH or comment out the fingerprint before attempting to re-join the device.


Hello Alwas,

SmartThings has ported the vanilla Groovy drivers to Edge.

The 500 series devices that are certified as WWST have already been added to the built-in “Z-Wave Sensor”.

Currently none of the built-in drivers are included in the platform so one need to manually install it from their channel:

We were wondering if you have tried it.

Hi @Sensative

Am I right that after installing the z-wave sensor driver the 500 series will keep operating as normal? And for the 700 you need the one from the startpost?

Yes @Roy_R, for the 700 series you will need the Edge driver.

1 Like

And the 500 series question?

Installing the z-wave sensor driver, the 500 series will keep operating as before.

1 Like

This driver causes a catastrophic failure in the most recent version of the Android app. Please see my related post.

Thank you @blueyetisoftware for bring this up, we are trying to get in touch with our developer, @krlaframboise , and we shall, too, try to investigate the problem.


The latest driver published today has resolved the issue. Everything works as expected now. Thanks.


Thank you @krlaframboise and @blueyetisoftware for analyzing and resolving this issue in short time!


@Sensative and @blueyetisoftware - I currently have version 2022-11-07T09:25:36.561226741 of the sensative edge driver installed.

The last two sensative strip guard 700s that I have tried to add to smartthings have been a disaster: in the case of both strips, the device will install, but not register any state change. (The strips are shown as “open” and nothing I do can change the state.

If I look at the strips in the old IDE they are shown as “cloud” executables, not local. This is has been a source of frustration for me for months – I simply cannot get them to install properly. I have tried adding them with the QR code, by letting smartthings scan for them, or by adding with the “manufacture->device type” method. They all produce the same result:

  • strip installs
  • strip shows online
  • no data comes from the strip
  • old IDE shows the device as running in the cloud

What am I doing wrong?

Information for devices using edge drivers can be inaccurate and incomplete if you try to look at them through the IDE. The IDE has never been updated for the new architecture, so you shouldn’t count on it in that regard. It shows a lot of devices using edge drivers as “cloud“ even though all edge drivers run on the hub.

To get accurate information about devices using edge drivers, you can use either the CLI, or a community created webpage interface called API Browser +. It’s not as easy to use the first time as the IDE was since you have to grant access, but after that, it’s got a lot of very helpful information.

Everything @JDRoberts said is correct…

Post screenshots of the device details screen and the bottom of the device settings screen so I can see the state of everything.

Do you by any chance have the WiFi hub?


Thanks @JDRoberts - I should have been more clear. Yes, I was aware of how all of this works, and I do check everything thru the CLI. I just found the information in the old IDE interesting considering these last two strips have been unable to successfully connect to the edge drivers.

Here’s one of the sensative strips exhibiting bad behavior. It’s correctly registered as a ZWAVE device…
131 North Gate sensative-strips-guard-700 ZWAVE 1bf65300-e4f9-4941-bf6e-2e9cb7161eba


hi @krlaframboise

Here’s the screens from one of the Sensative devices. (No, the battery is not at 1%, it’s a brand new device, it’s just not reporting any information.)

My Hub is a V2, and it’s connected via ethernet, not WiFi

Does the tamper tile change when you manually wake it up? The wake up procedure is the same as inclusion.

No, it doesn’t. That’s why I started poking around in the IDE. It doesn’t look like ST Hub is receiving any data from this device beyond the initial inclusion.

This has been true for this device and another I added afterwards. Since these things are relatively expensive, I didn’t want to waste any more until I have a thorough understanding of what is happening.

This is interesting @krlaframboise - I just took a look via the API Browser (which I didn’t know existed, so that’s fantastic) and I can see that it is failing the S2 security check:

1 Like

Try rebooting your hub.

Did you use the qr codes on the device when adding it?

I will give the hub a reboot later today and see if that helps.

Yes - I used the QR codes…I also tried letting the hub scan for new devices, and using the “find by brand/model” option when onboarding. All three methods have the same effect