[ST Edge] Virtual Things Edge Driver

@Sakari what device status do you see in IDE?

Ok. This makes sense. I think I’ve read about this from some other thread.

@Sakari I thought the changes are propagated only to capabilities and was extra careful to create a new one, instead of modifying the already published, but unfortunately it didn’t help

Status is online. That is pretty much all info there is to see in IDE for Edge devices. :grinning_face_with_smiling_eyes:

@Sakari that’s good news, thank you for sharing.
Seems like the issue with partial update affects only APP, not the platform

1 Like

Good to know it’s not an issue with my hub. Thanks man.

Hi all,

I posted an update to the virtual things driver.
This should fix checking status issue as now capabilities are synchronized with the code.
The update includes

  • smoke sensor
  • alarm
  • thermostat (it contains the thermostat logic, but I do not know yet how to push the data from the external sensors to it)

You might need to force stop the APP and clean its cache.


Deleted the driver, installed it again and now it works! :+1:

1 Like

@Sakari great, thanks for sharing this

Sure. This goes both ways. You develop and we use. :grinning_face_with_smiling_eyes:

I can’t get the new version to work.
It says checking on the device tile
When I try to select or create a virtual device, I get network or server error.
I closed the app, force stopped it, cleared the cash and restarted the phone several times. Nothing worked.
Used Android 9 phone with current app and old Android 7 table running and older version of the app. Both had the problem.

@Paul_Oliver ,

The upgrade might take up to 12 hours I think.
If you prefer not to wait, you can delete the driver, unenroll from the channel and enroll again, then install the driver.

If you have virtual devices used in automations and prefer not to remove them, then I would suggest to wait 12 hours, then to delete the controller and then clean the cash.
After that, just scan for new devices and the controller will be created again.

I will wait the 12 hrs. and see what happens. I have a number of your virtual switches used with Alexa so I don’t want to unenroll.
I will report back if I still have problems tomorrow.
Thanks for your hard work.

1 Like

@Paul_Oliver Just wanted to make sure, other devices (except the controller) work normally, is it correct? I only changed the capabilities of the controller in the new version, so anything else should not be affected.

Are you using the switches as an event source for Alexa routines? Does it work reasonably fast for you?

Yes, I use a half dozen of your virtual switches as triggers in Alexa and they have worked well.
I just go notified by Alexa that I have mail, so the switches are still working.
It is only the driver that generates the devices that is not working.

1 Like

@Paul_Oliver , great, thank you for the update

Deleted and reinstalled your driver and now I am able to create virtual devices.
Thank you again


I am having problems again. The driver get stuck with a status of “creating” when I try to create a new virtual device.
I have rebooted the hub, closed the app, forced stopped the app, cleared the cache deleted the driver and reinstalled the driver.
I did NOT unsubscribe from your channel because I didn’t want to lose the devices I have created.
Deleting and reinstalling the driver resets the driver to ready, but nothing gets it to create a new virtual device.

Hi @Paul_Oliver ,

If you want to keep the devices, created by the driver, the driver should not be deleted. In fact, I think attempting to delete the driver with devices should fail with ‘driver in use’ error.
If the driver was indeed removed due to some platform’s issue, but you still have the devices, I really doubt they are functioning properly.
If you can confirm the virtual devices are responding and the automations, associated with them keep working, I will assume the driver was not deleted.

I did not do any modifications to the driver since the last update. Not even to my dev channel. So, the first thing to investigate is whether drivers stops responding after some period of time due to some other issues, perhaps network disconnect. Another thing I’d like to check is whether it could be related to the amount of virtual devices, created with the driver or even with the specific type of the virtual device.

  1. Can you please confirm the virtual devices, created with the driver responding and working correctly?
  2. What status for the virtual devices and controller do you see in IDE?
  3. How many virtual devices were created with the driver?
  4. What kind of device you were trying to create when the Controller got stuck?
  5. How many devices of that type you managed to create (before the unsuccessful attempt)?
  6. Would it be possible to retrieve the logs from the driver? You will need to install smarthings cli and run it from the command line.


It looks like I currently using 8 virtual switches, 1 contact sensor and 1 presence sensor created by your vDevController. All virtual switches are use as Alexa triggers.

Experimenting I created another 6 to 12 devices, but later deleted then.

They all appear to work except for the presence sensor. It will not change state using the button. When I open the device it shows ON and NOT PRESENT.

The driver and all virtual devices created show as on line in the IDE.

I do not have CLI installed. Is this something you install on a PC or mobile device?

I am going to delete the nonfunctional presence sensor to see if that makes any difference.