[ST Edge] Somfy Connexoon Edge Driver

Somfy Connexoon Edge Driver

This is a Smartthings Edge Driver for Somfy Connexoon.

The driver has been developed to work with Connexoon Hubs and currently only supports the discovery of Somfy blinds (Using Somfy’s RTS Protocol). More Somfy devices can be added (Roller shutters, Windows, Curtains, etc) - Just ask me!

The edge driver should also work with Somfy Tahoma Hubs. However, this has not been tested.


You will need the following hardware:

  • Smartthings Hub
  • Somfy Connexoon Hub


1. Configure your Connexoon hub

Register all your Somfy RTS products on the Connexoon using the instructions that came with the product. Then, activate your Connexoon at https://www.somfy-connect.com.

2. Generate and Activate your API Token

An API Token is required for sending authenticated API requests from Smartthings to the Connexoon over the local network.

Generate and Activate an API Token using using the instructions here. The important sections to complete are:

  1. Getting Started - Enable Developer Mode
  2. Login
  3. Generate a token
  4. Activate your token

Australian users should use the same instructions above but replace {{url}} with ha201-1.overkiz.com

3. Channel enrollment and driver installation

Enroll your hub into my Smartthings production channel here. Then, find and install the Edge Driver called ST-Edge-SomfyConnexoon.

4. Discover the Somfy Connexoon in Smartthings

In the Smartthings app, you can now discover the Somfy Connexoon.

Open the Smartthings app then select Add device > Scan for nearby devices

Once the Somfy Connexoon has been discovered, it will appear offline until you configure the IP address and Token in the device settings.


5. Configure the device settings

Open the discovered device then tap the vertical ellipsis and choose settings. Here you can enter the IP address and Token for your Connexoon.


Get the IP address by pinging gateway-{pin}.local, where {PIN} is the PIN recorded on the bottom of the Connexoon. For example, gayeway-1000-2000-3000.local.

It is not possible to set a static IP for the Connexoon. Consider setting an IP address reservation on your router instead so that the IP address does not change.

If everything has been configured correctly the Somfy Connexoon should be online and connected.


5. Discover your Somfy devices

Tap on the Discovery button to find all your Somfy devices. You will see them appear as seperate devices on your dashboard.

screenshot_dashboard screeenshot_WindowShade


Hi Damien. This is great. Exactly what I’ve been looking for since i got my Somfy box around a year ago. I only have one issue. When I discover devices, it only discovers 8 of my 12 Somfy blinds. I’m not sure why it doesn’t find the other 4. Any ideas?

Hi Richard,
Glad you like it :slight_smile:

In order for me to look into this issue I will need you to send me the configuration of your Somfy box.

  1. Go to Swagger UI
  2. Enter your PIN (Located on the under side of your Somfy Box)
  3. Enter your port (8443 by default)
  4. Click on Authorize, enter your token, and click authorize.
  5. Scroll down to ‘Setup’ and select ‘setup/devices’
  6. Click ‘Try it Now’
  7. Click execute
  8. Copy the Curl command and run it. I like to use Postman. You can download it for free and its easy to import Curl commands and run them.

Share the response and I’ll take a look for you.

Hi Damien. Thanks for your assistance. The response is too large to include here, so I have shared it here: https://www.dropbox.com/scl/fi/rhku6p2ru49musuf6sksa/somfy.txt?rlkey=ill1nyfeeqmb18ww5p8hl521i&dl=0. It is the 4 roof blinds that are not being discovered.

Hi Richard,

I have updated the driver and it now supports your roof blinds.
New verson: 2024-02-08T05:36:09.314379511

Your driver will update automatically in time. When the version has updated run the discovery again and your roof blinds should be detected.

Let me know how you get on.


Working perfectly now. Many thanks!

any experience with Somfy Connectivity kit ? thanks

Hi @VRampa,

I haven’t got experience with this specific device. I have had a quick look though and it may support the Somfy local api, in which case the driver will work.

Feel free to give the instructions a go to test it out. If you get stuck I’ll help you where I can.

1 Like

from the Somfy website I can’t enable developer mode (it sees it as a Tahoma), I can only reset the box

Hi @VRampa,

If you cant enable developer mode then this integration will not work for your device.


Hi Damien, I was very happy to discover your driver to integrate the Somfy switch with SmartThings. I have a Tahoma switch controlling some awnings and a sun sensor. I am a little out of my depth but managed to follow your instructions and I have your Somfy Connexoon running in the SmartThings app and the status is “Connected” but it does not discover any of the devices. Could you please provide some suggestions to figure out why this is not working. Thanks.

Hi Peter,

Sure, I can take a look for you.

In order for me to help I will need you to send me the configuration of your Somfy box.

  1. Go to Swagger UI
  2. Enter your PIN (Located on the under side of your Somfy Box)
  3. Enter your port (8443 by default)
  4. Click on Authorize, enter your token, and click authorize.
  5. Scroll down to ‘Setup’ and select ‘setup/devices’
  6. Click ‘Try it Now’
  7. Click execute
  8. Copy the Curl command and run it. I like to use Postman. You can download it for free and it’s easy to import Curl commands and run them.

Share the response and let me know the names of the devices as configured in the Somfy app and I’ll take a look for you.


Hi Damien,
Thanks for your help. You can find the output in a txt file here:

Hi Damien,

I have posted the output from Swagger UI as you instructed (via a shared Goole Drive file). Is there anything else you need from me?


Hi Peter,

Sorry for the delay.

Ive updated the driver and your awnings should be discoverable now. The new version is 2024-05-17T06:15:47.502261597. Your driver should update automatically.

I note your devices use the io-homecontrol protocol whereas this driver was originally created for motors using the RTS protocol, The main difference is that io-homecontrol has bidirectional status where as RTS does not.

You might find the status (open, closed, partially open) becomes ‘out of sync’ with your other controllers.

let me know


Hi Damien,

Thanks very much, the awnings were all discovered. Only the sun sensor was not discovered. Is there anything you can do about that?

The opening and closing of the awnings works well. The only minor issue is the pause button. On the Somfy system this button has 2 functions;

  1. when the awnings are closed, pressing the button opens the awnings to a pre-set position (called my).

  2. when the awnings are in motion, pressing the button stops the motion.

The button works perfectly when the awnings are in motion but when they are closed and the button is pressed, the status is changed to “partially open” but awnings don’t move at all. This is not a big deal but would be nice if it can be fixed.

Thanks again for your work on this. It will be fantastic to have everything controlled from SmartThings.


Hi Damien,

Thank you for this great work !
I’ve just tested the integration of your work but nothing comes up with the synchronization.

My configuration is as follows:

  • Tahoma V2 box
  • Roller shutters (io-homecontrol)
  • Temperature sensor (io-homecontrol)
  • Light sensors (io-homecontrol)

And if you’d like, I’d be happy to try and expand on this pilot that interests me.

The result of endpoint setup/devices : response_1716148714731.json - Google Drive

Hi Peter,

Regarding the preset position: I can update the code to facilitate this. Before I do, how is a preset (‘my’) position programmed? Is there a button on the physical remote?

Regarding the sensor: Can you send my a picture on how this is represented in the somfy app. I will look into reproducing it for you.

Hi @jdefr42x

Ive updated the code. Your shutters should be discoverable now.
Version 2024-05-20T08:18:56.744287546

Can you send some pictures on how the sensors are represented in the Somfy app. Ill try to reproduce it for you.

Hi Damien,

The preset position is set with the pause button (which is also the stop or pause button between the up and down buttons) on the remote and is labelled “my”. The position is set by moving the shade to the desired position and then holding the my button down for 5 seconds (the shade responds with a short up-down movement to indicate that the position is registered in the motor). The preset position can also be erased by moving the shade to the position and then holding down the my button for 5 seconds. When the shades are in the closed position, a brief press of the my button will open the shade to the preset position. Here is a picture of the remote:

Somfy afstandsbediening - Situo 5 io ...

I have attached a screen capture of the sun sensor icon on the app. Within the icon it shows the current lux value that the sensor is reading.

I hope this helps. Please let me know if any further info.