[ST EDGE] Monoprice 4 in 1 Motion Sensor (ZP3111US-5)

I don’t see any there either. Since nothing’s coming into the hub I would tend to blame the device. First thing I would check is whether the hub node is in Association Group 1 - if that didn’t happen as part of inclusion then it can certainly cause problems.

Or, if you haven’t tried it already, exclude/include. I’ve had some difficulty with the Zooz branded ones before. Never tracked down the cause, but they seemed to prefer including close to the hub.

BTW - I find logs to be more readable on the forum if they’re in a code block. Putting three ``` (the backwards quote that shares the tilde key) on a separate line above and below the logs will do that. It also makes the forum more accessible for those that use screen readers.

I have included and excluded the device a many times or the last few days with no difference. It worked fine with the old DTH.

I always pare battery operated and some hard wired devices next to my hub. They I let them set for a couple minutes before I do anything.

I will check the association group.

How would I check the Association Group?

It’s a sleepy device, so the only way to interact with it is in a function that’s called on wakeup. That driver already has it set up though - you’d add any lines you want called to the update_preferences function of zwave-sensor/src/init.lua.

This will get the association group nodes in group 1:

device:send(Association:Get({grouping_identifier = 1}))
1 Like

Thank you for your input, @philh30, it’s really helpful.

@Paul_Oliver, did you only change the device profile?
When working with subdrivers, there’s a function called can_handle which checks if the device is accepted by it or not.
If you didn’t add the corresponding values in ZOOZ_4_IN_1_FINGERPRINTS for this device, then, that might be causing the issue…

1 Like

I pared it with both the stock driver and the one I modified and got the same results.

In the modified version I only charged the profile for the multi-functional-motion. I changed “categories: -name” from MultiFunctionalSensor to MotionSensor to get the correct icon.

Would you add the to the main driver or the Zooz sub-driver?

The main driver


That seems to have fixed it.

I substituted you suggestion device:send(Association:Get({grouping_identifier = 1}))
device:send(Association:Set({grouping_identifier = value.grouping_identifier, node_ids = _node_ids})) that was in the original code.

Thank you very much for taking the time to help me again.


Excellent! I’m glad you got it working! I do remember Kevin having logic in his 4-in-1 DTH to double check that the hub node is in group 1, so it might be something with this device where it occasionally fails to pick that up when added. Now that you have this device set up, you can delete (or comment out so it’s there in the future if you have trouble with another of these) that Association:Set command so it doesn’t waste battery by sending that every time your device wakes up.

Also, if you haven’t done as @nayelyz suggested, then you need to add your fingerprint to the sub-driver’s can-handle. If you didn’t do that, your device is only using the main driver, and isn’t picking up any of the handlers defined in the sub-driver. The sub-driver has logic to handle the z-wave commands for tamper, motion, and lux that doesn’t match the default handlers that the main driver would use.


The Monoprice fingerprint was already in the stock version of the sub-driver.

How do you comment out at line in a Edge Driver? I know you used // in a DTH.

1 Like
-- This single line is commented


For the block comment, you can add a third hyphen to the top line (e.g. ---[[) to easily toggle the code back to being active.


Hello @philh30 and @paul_Oliver

Indeed, with that format it looks better, but if the log is a bit long, it blocks the mobile browser, (chrome android), for a while or always, when the thread is opened and it forces to see it on the PC, I don’t know if you this happens too.

Another way to put the logs or photos, which another user taught me and that does not clutter the post, is to put it as Hide Details, by clicking on the gear icon, top right


2022-03-05T11:32:55.669828702+00:00 TRACE Z-Wave Switch  Received event with handler capability
2022-03-05T11:32:55.759244035+00:00 INFO Z-Wave Switch  <ZwaveDevice: bd5c15c7-76f5-4430-b95d-c8ea349e9f61 [1E] (Luz Entrada)> received command: {"component":"switch1","capability":"switch","positional_args":[],"command":"on","args":[]}
2022-03-05T11:32:55.788305369+00:00 TRACE Z-Wave Switch  Found CapabilityCommandDispatcher handler in zwave_switch
2022-03-05T11:32:55.857030702+00:00 TRACE Z-Wave Switch  SWITCH_BINARY supported.
2022-03-05T11:32:55.934287036+00:00 INFO Z-Wave Switch  <ZwaveDevice: bd5c15c7-76f5-4430-b95d-c8ea349e9f61 [1E] (Luz Entrada)> sending Z-Wave command: {args={duration=0, target_value="ON_ENABLE"}, cmd_class="SWITCH_BINARY", cmd_id="SET", dst_channels={2}, encap="AUTO", payload="\xFF\x00", src_channel=0, version=2}
2022-03-05T11:32:56.040529369+00:00 TRACE Z-Wave Switch  Z-Wave command(cab3ad73) queued for radio transmission: CC:Switch Binary, CID:0x01
2022-03-05T11:32:56.077159036+00:00 DEBUG Z-Wave Switch  Luz Entrada device thread event handled
2022-03-05T11:32:56.104420036+00:00 DEBUG Z-Wave Switch  Luz Entrada device thread event handled
2022-03-05T11:32:56.186697036+00:00 TRACE Z-Wave Switch  Z-Wave command(cab3ad73) transmit status: TRANSMIT_COMPLETE_OK

Hi @Paul_Oliver did you ever get this device to connect properly? I can’t get motion working. Tried pairing/unpairing multiple times and it’s not picking up motion. Let me know which driver you’re using. Thanks

Sorry for the delay in responding. The following is your solution.

Excellent! Thank you

Does this edge driver work with the monoprice 15269 shock/ acceleration sensor? I can’t find how to assign the driver, it just shows up as an open close sensor with no “driver” option. Wondering if my fingerprint is different.

Post your fingerprints. You can find the in the IDE in the data section for the device.

Data * MSR: 0109-2003-0307

  • networkSecurityLevel: ZWAVE_S0_LEGACY

Raw Description zw:Ss type:0701 mfr:0109 prod:2003 model:0307 ver:16.06 zwv:4.24 lib:03 cc:98 sec:5E,22,85,59,80,5A,7A,72,71,73,86,84

Is it in there somewhere?

I believe the 1st line contains the fingerprints. I don’t see the fingerprints in the stock driver.

Your could ask @philh30 or @Mariano_Colmenarejo if they could add the finger prints to their Z-Wave sensor driver