[ST Edge] LAN Device Monitor

As described in your post, mine were running fine as is, but unable to create anymore if needed.

So…I deleted them all this morning and added this new updated version.
Everything seems to be working as expected, so far. Set up a few of the automations and these are running fine.

Thank you for staying on top of all this craziness this week!:+1:

1 Like

@Nezmo, @Sakari

I think I’ve had someone use this driver to be able to monitor their Xbox, so you might want to just check in the Xbox configuration settings to see if there’s some option that needs to enable UPnP.

Whether or not a device is discovered via UPnP can depend on whether the device responds to the standard discovery search targets. Some devices may say they support UPnP, but they may only respond to very targeted, custom search strings.

There is another way to discover devices on your network, and that is through what is called mDNS (multicast DNS). This is an entirely different protocol than UPnP, but many network devices support it. I have an mDNS Discovery driver that I posted a while ago that you could experiment with if you are curious to see what it can find on your network. It’s just a general purpose query tool in its present form. I didn’t get much interest in it, so I never turned it in to any kind of ongoing monitoring driver like LAN Device Monitor.

1 Like

Thanks for your patience; glad you are back up and running, although I hate when users have to start all over like that!.

Honestly, I felt worse for you! Been quite a hectic week and was prepared to do the change on the release as needed.

They seem to be working fine so far and havent seen any glitches that I’m aware of so far.

Again, thanks for all your work in this community.

I have enabled the upnp settings in my all my devices.

I also tried mDNS Discovery when you published it and it can only pick up my RPi runnin LibreElec

@TAustin
I may have had a small glitch this morning with LAN Device Monitor (LDM) and Virtual Edge Momentary Button press (VMB) in a routine that partially ran. By the time I could get the Cli open this was the same 2 lines repeating over and over.

2022-06-21T16:26:35.192583272+00:00 DEBUG LAN Device Monitor V1.3 [upnp] Running device expiration check
2022-06-21T16:26:35.198481272+00:00 DEBUG LAN Device Monitor V1.3 driver device thread event handled

I just ran this routine again and it ran fine this time. This is a routine I’ve run ever since the creation of the WOL function. The 2 lines of code from above are from now, but it was those same 2 lines that were repeating this morning at 0530EST.

EDIT: the 2nd attempt it worked as it should…

What does the virtual button and your routine do, exactly? Is it turning on/off Monitoring for a device?

Those two lines would be fairly typical for a driver that is running but there are no devices being monitored. A “device expiration check” is run at whatever frequency you have defined in ‘Polling Interval’ in the device Settings. So you are just seeing that routine being invoked periodically.

Maybe somehow the device monitoring didn’t get properly restarted.

You would have had to recreate or modify this routine when you installed and started using the new driver I just released.

Keep me posted if you see it happen again.

My friend, my drivers never seem to work well on your network and I wish I knew why!

There are UPnP tools available for Linux that you could try to see if you have any better luck finding UPnP devices. One that I’ve tried and seems to work pretty well is called Miranda. If you google Miranda UPnP, you’ll find it.

You have to be a bit careful with the order of things when you use the mDNS discovery driver in order to make sure you find everything available. Did you follow the steps I outlined in this post?

After you use ‘Execute a query’ for the command ‘List Service Types’, you should get a list of several service types. How many do you get?

You then need to check each one in turn by first selecting it in the top field, and then choosing ‘Get Service Instances’ in the 'Execute a query field. You’ll have to keep doing a ‘List Service Types’ command between each one so you can go back to the list of service types.

This is the basic version of just this routine. It presses the WOL button for me when I ask Bixby to turn the computer On. Then when LDM switches to On the media player and Audio system both get turned On.

The LDM never turned On, so thats presumably why I was seeing this, but the WOL turned the computer On. This is why I was kind of scratching my head going…Hmmm.

I most definitely did this.

That post was more for a record to refer you back to if it happened again. I believe it was an odd glitch, but just wanted you to know about it.

The UPnP monitoring and WOL are two separate and distinct functions. So it sounds like you aren’t using this driver to do UPnP monitoring, but rather for triggering the WOL function. I hadn’t understood that earlier, sorry!

The WOL message goes out as a multicast UDP message. As such, these messages don’t have the same level of reliability as TCP-delivered messages. So it certainly could be possible that the WOL message got sent but never received. Keep an eye on it and let me know if you see any more problems.

1 Like

I’m not sure. It’s been quite some time when I tried it. I could check it out again and see if I can get more out of it.

Hi @TAustin,

The Lan Device monitor driver It was working perfectly and today has stopped working.

The 2 devices have stopped reporting the status of the TVs they were monitoring.
The TVs IP are statics and are correct in preferences

The first thing I see is that the Device Monitoring on/off button doesn’t work, if you put it to Off you can’t put it back to On.

After many tests, I have come to uninstall and reinstall the driver and devices and I have put the CLI.

  • It is seen that the driver is inactive, the monitoring timer is not running.
  • If I change the Device Monitoring on/off button to On it always returns to Off, although the button icon status is always on.

@Mariano_Colmenarejo

Check out post #95. Looks like you should go ahead and update to V1.3.

1 Like

Thank you,

When I uninstalled it, I downloaded the driver, but I thought that the version that doesn’t work would already be deleted of the channel and I downloaded the one that appears first in the channel, I didn’t see v1.3

This seems to work, thanks again

2 Likes

I installed mDNS discovery and it is also showing all clouds.

Ugh. Thanks for letting know. I had not updated it after the Android issues. I’ll get you an update later today your time.