[ST Edge] LAN Device Monitor

Hi, I use your LAN Device Monitor to check the satus of my Synology NAS. It sends messages as soon as the NAS is turned off, and WOL works fine too, I can turn the NAS On with your “wakeonlan” button anytime. But I have two problems:

  1. After my NAS is powered On again (after an Off state it is available again), I can still see it as “Off” by your LAN Device Monitor forever, however I tried 10–30s polling time intervals. As soon as I turn your monitor Off and On again (with your monSwitch button), it shows my NAS as On until the next Off state. I tried to create a routine to turn Off then On your LAN Device Monitor when it detects the lost of my NAS, but it does not work in routines, I can send Wake On Land command only, but not control your monitoring.
  2. There is an “Untitled” text over your create new device button (but works fine), not something like “Create new device”.

I have been using the WoL feature with my Synology NAS also, works great but was unable to get the status to work - could you share any tips?

Hi @TAustin

I just installed your driver version 1.3 and I can’t connect to 2 devices:
computer and LG Tv

there is any way to fix it?

Are you certain that those devices support UPnP? Even if they can, sometimes it has to be explicitly enabled through config options on the device.

I’ve never had success with a Windows computer.


And LG G1 Tv should work?

I don’t know; you’d have to find out if it supports UPnP.

@TAustin @Liran1115 I posted above that the WoL was working for my Synology NAS but the monitoring wasn’t, the important point I missed was clicking the monitoring button. Doh!

:laughing: yes it helps to turn it on! Thanks for the follow-up.

1 Like

Hello, is it possible to add printer icon? Thx

I don’t know that there IS a printer icon, is there? If you’ve seen one on another device, let me know what it is so I can look into it.

It is screenshot from Samsung Smartthings power outlet (power outlet was in package with v2 hub UK)

Hi @TAustin

In order for these icon options to appear in the app menu edit, you must put the profile with the SmartPlug category.

If someone uses any of those icons from the edit menu, they will no longer be able to switch to icons offered in preferences until uninstall and recreate the device.

The icons in the app’s edit menu take priority over the icons assigned in the profiles

1 Like

So here’s the deal: I had provided for the ability to change the icon to a specific set of alternatives in device settings. However I kept the device category itself to ‘switch’, so that it would still be recognized as such by other apps (Alexa, for example). The downside of this is that you don’t get the variety of icons available through the device edit menu for different categories of devices.

It is possible to add a device setting to choose to retain the switch device category vs. customize it based on icon selection. This would double the number of device profiles I need to create and maintain and add a little bit of code, but it is doable if it’s a critical requirement.

For me - it is definitely not a critical requirement… Thank you for your reply

Well don’t give up hope. I’m thinking about this some more. And my opinion is that using the switch control in this device (which is used for turning on and off monitoring) from some external source like Alexa or Action Tiles, is probably a pretty rare case. And therefore trying to preserve the switch category should not take precedence over providing a wider choice of icons. Afterall, this is a monitoring device for monitoring all sorts of different things, so it certainly should have a wide choice of icons.

So I think I’ve talked myself into it: I’ll go ahead and make the needed changes so that you’ll have access to more icons. Give me a day or so to get it done.

1 Like


I have pushed out an update to the LAN Device Monitor driver with these changes:

  • Fix to labels on device Controls screen (you will have to create a new device to get the corrected labels)
  • Change to the way the device is updated when you choose a different dashboard icon from the Settings options: previously the icon was changed without changing the device category, which was always defined as a switch category device no matter the icon. After this change, the device category will change along with the icon. In some cases this will provide access to more icons. For example if you choose a plug icon, then you will have new icons selectable from the device Edit menu that weren’t available before.
    • If you have an existing LAN Device Monitor device and want to benefit from this change, simply choose a new icon from the Settings options. If you already have plug selected and want to get the additional icons, temporarily change the icon to something else, then change it back to plug. This way, you don’t have to create a new device. (@Neudy)
  • A ‘multifunction sensor’ has been added to the list of dashboard icon options. As noted above, this will also provide access to further icon choices in the device Edit menu. A new device will need to be created in order to see this new option listed in the Settings options.

Updated Driver Version: 2023-01-18T01:17:18.191320741

This update will be automatically installed on your hub, so no action is required other than those noted above.


Can I ask - how are you doing this? I am new to Tasker and I can’t, for the life of me, figure out how you can switch on and off a device from it?

I was using Life360 - which is now kaput.

Switched to Tasker so my other half can have it running in the background and not even have to do anything which is paramount for my sanity haha

Current way I am doing this is:

Tasker → Wifi Connected → HTTP POST to Sharptools → Turns on Smartthings Virtual Edge Presence

It looks as though you have a FREE version of doing this by your images? How do I trigger a virtual device using HTTP POST? Is the web address a simple api.smartthings.com/v1/home hub name/room location/device?

Please do let me know or point me in the right direction if you can, would save me a fee which I hate paying for

Would just like to say I figured it. Was all spelt out here and took some long winded Googling for it to show up haha:

Works like a dream so far!


I’m glad it helped. If you need any further help with tasker please feel free to reach out.

1 Like