Aeotec Water Sensor 7 Basic not working

Just installed the Aeotec water Sensor 7 and enrolled in the Edge Driver for the same. The driver is on my hub but is not shown as an option from the app. The device installed as a generic z-wave switch and is not working and thus why I am trying the Aeotec edge driver.

From the web I get the following error

I bought Aeotec as I assumed their stuff would work properly. Edge Drivers are killing me and all of my security and safety related devices are still not working properly.

What am I doing wrong?

That generally indicates that the driver doesn’t have the fingerprint for your device. What does the Advanced Web app show as the fingerprint for that device?

I ended up deleting and installing without QR code and it installed with the correct Aeotec edge driver though it won’t stay connected and keeps going offline. I really dislike this new edge driver mess. Frustrating

Is there something I can be looking at to determine why this goes offline? My previous Aeotec water sensor worked for years and when the edge driver change happened it fell off network daily and batteries started draining. I assumed the sensor went bad and bought a new sensor and it dropped off an hour after getting it working. My hub is close. Something odd going on. I need reliable water and smoke sensors and am ready to switch to a different hub.