[ST Edge/Beta] Xiaomi/Aqara/Tuya zigbee sensors driver

For frame of reference adding this item. I tested with these two device convertors to use this device ( _TZE200_dwcarsat ).



If there is a github for this edge driver I would be happy to make a pull request for it

Just to follow up, I moved my 2.4GHz router to channel 11 and the SmartThings hub to channel 11 (via the IDE), as strange as it seems this puts both devices a long way a way from each other on the spectrum and helps avoid interference. I dropped the old sensor so ended up having to purchase a replacement which connected quickly and has been connected ever since… I also purchased another Aqara motion sensor for the house and that’s also been behaving! Thanks for the advice Sergei :-).

1 Like

Anyone can guide me on how to pair the Aqara Vibration Sensor?

A fingerprint from the IDE:


  • application: 02
  • endpointId: 01
  • manufacturer: LUMI
  • model: lumi.sens
  • zigbeeNodeType: SLEEPY_END_DEVICE
    Raw Description 01 0104 5F01 01 05 0000 0003 0019 FFFF 0012 07 0000 0004 0003 0005 0019 FFFF 0012

Can this device be added @ygerlovin ?

Hi @ygerlovin! Can you please add these two devices? The first one is the Tuya Smart Zigbee Button Wireless Switch.

The second device is MOES Tuya ZigBee Smart Window Door Gate Sensor Detector.


I will be very grateful for your help.
Of course if possible.

I asked Yagerlovin for this months ago…nothing but @w35l3y has it working perfectly with this driver, including pm2.5… [ST Edge] Personal Tuya Devices - Generic EF00 Device - Devices & Integrations / Community Created Device Types - SmartThings Community

1 Like

This driver below should handle with EF00 cluster…


This is the current list, not limited to:

This driver will also try to handle unknown devices for similarity with other predefined devices.
Also, if it doesn’t match anything, it will let users to map the datapoints according to their own searches.


I introduced your driver to the largest iot forum in Korea.
This driver is said to work well for Tuya products without edge drivers.
That’s why we call this driver “the all-around/DIY edge driver.”
So I’m especially grateful to you.


Hello Joey
Is this driver working ok for you for _TZE204_ztc6ggyl?
Like all cappatibilites? presence, sensitivity, set delay, set range, illuminance.
Or is usage more limited than when added via Tuya app? :slight_smile:
I’d like to use Target distance variable as trigger.

The driver only allows a trigger of presence, Illuminance and signal strength.
It allows the below settings, although I’m not sure all work well and have the correct ranges. Sensitivity does seem to work. With this device, you really need to tweak some settings. Right now, I’m not too confident in the far detection. I’m fine for my one device for testing, but I wouldn’t buy more until I am sure on settings working properly with the correct ranges.

@ygerlovin Looking for assistance as I didn’t see any resolution reading this post. I too am having issues with my Aqara motion sensor (RTCGQ11LM) going off line after a few hours. I have replace the battery and get the same result. I have notice when I add the device the battery level is 0 and the voltage is also 0 and they never go up before it goes offline. But I have the Aqara P1 motion sensor (RTCGQ14LM) and it’s been rock solid.

Hey, fine?
Same model Here:

Is there already any driver solution?

My dear friend @w35l3y is trying with me his driver version but i had no success by this moment. Maybe another version…

Do you have fresh news, someone with the device working all right?


As I said in private message, I can’t help you without the logs.
I borrowed it from a neighbor and the driver was working for this device.
I need to see the logs to understand why it isn’t working for you.

Guys - I’m at a complete loss and I suspect its IOs. When you install the edge drivers, how do you change the driver?

I’ve seen numerous threads about using detailed views, pressing 3 dots and change driver. But there is no such options. I’ve been working on this for a few days now. Is this a problem with IOs smarthing app? When you do respond please respond with pics. this will assist me thanks

@ygerlovin What am I missing? Still no luck using the driver keeping my Aqara motion sensor (RTCGQ11LM) online even when sitting 1 foot from my ST hub using the Zigbee Sensors Edge Driver [YG] edge driver. Any recommendations?

1 Like

Hello @ygerlovin,

Where can I find the device list your driver is supporting?
I want to know if your device supports this Moes product:

[US $48.99 40%OFF | MOES Tuya Smart ZigBee Human Presence Detector Radar Detection Sensor Photometric 2 in 1 Function Smart Life Ceiling PIR Hub https://a.aliexpress.com/_EG0V5Q9](US $48.99 40%OFF | MOES Tuya Smart ZigBee Human Presence Detector Radar Detection Sensor Photometric 2 in 1 Function Smart Life Ceiling PIR Hub https://a.aliexpress.com/_EG0V5Q9)

Thank you.

1 Like

Good evening,@Gmanor77 this presence sensor by Moes (Tuya) already has a driver, the Tuya Presence Sensor driver from @iquix

I have DJT11LM vibration sensor that worked ok under Groovy DTH. I’ve since migrated it over to Edge drive “Zigbee Sensors Edge Driver [YG] 1.8.16” and it seems to scan and add fine. However, it’s going offline after about 24hrs. I’ve tried deleting and adding vibration sensor back three times now and it doesn’t stay online beyond a day. Swapped in new battery just to rule out low battery but still same results of going offline after a day. Any suggestions to try to keep it online?

If you haven’t already read the beginning of this post please read it as the OP has written some very useful information.

I had the same issue as you with open/close and leak sensors and I spent some time sketching out my layout and looking for holes in it which led me to add additional Zigbee plugs to my system and increase the network coverage and that solved the offline problem for me. The only times I’ve had to reconnect some of them is after a hub firmware update.

This vibration sensor has been in use for a couple years now in same exact location under Groovy DTH and only dropped off on dead battery or after house power outage. Also, there’s an Aqara motion sensor and a temperature sensor within that same room that haven’t dropped off post migration to Edge drivers. I’ll try re-adding it some more times before moving on to something else.