Speaker companion says "." or dot before message on Sonos

smartapp

(John) #1

I am new to smart things, trying to test saying a message when a door sensor opens with sonos

it works, but my message is “Door Open”, sonos says “dot door open”

anyone seen this before and know a fix?


(Steve ) #2

What you using to send the message?
I use big talker smartapp you should give that a go if your not using it works great for me.


(John) #3

I am using “Speaker companion” guessing that is Samsung’s built in app, will try to find “big talker” and try it


(John) #4

took me awhile to figure out how to install “big talker” , I added to api.smartthings and would not show up in app

finally figured out I need to click on my location on locations tab then add it, other wise it was just added but not applied to a hub

and yes, it worked, no longer get the word “DOT” before my message, smartthings should really fix that issue though

thanks for you help


(Steve ) #5

Nice one you should have asked about the installation.


(John) #6

:slight_smile: I was about to ask, I like to play first, try to figure it out, think you learn more that way

been trying to find a backup\restore in case I break something, is there a way to go to last known good


(Steve ) #7

You’ll be looking forever for the backup…
For some reason they don’t have a backup feature which is daft as I’ve added loads of devices now and routines etc would take me ages to set back up


(Aron & Kwang) #8

Okay, I’m brand new to SmartThings. How do I find and install “Big Talker” on my system? Thanks!


(Aron & Kwang) #9

Also, regarding Speaker Companion, is it possible for me to play a notification is the temperature goes above a certain level?


(Steve ) #10

This is big talker read the guide on how to set it up.
And yes you’ll be able to set alerts up for that.


(Aron & Kwang) #11

Thank you! I tried both methods (manual and the respository). The manual
gave me an error when I copied the link and clicked “create”. The
respository method seems to have uploaded on my computer, but I can’t see
anything called My Apps in the SmartApps folders…


(Steve ) #12

Sorry didn’t notice your reply.
Did you manage to get it working


(Aron & Kwang) #13

No. I didn’t since my fails on the 2 methods :frowning:


(Steve ) #14

Have you installed smartapps before?
Just wondering what method your trying.
Log into your IDE , make sure it’s the correct one as the US and Europe have different.
Then goto smartapps , then new Smartapp and click from code and copy and paste just the raw code from here.


Then save but then it needs publishing.
Once done you install it through your SmartThings app in my apps


(Aron & Kwang) #15

Yes this is the first time doing this. I get to this page but cannot copy
and paste the code into here.

I try select the entire code and copy, but when I paste nothing pastes…


(www.rboyapps.com - Make your home your butler!) #16

Looks like you’re trying to do it from your Android phone, reboot your phone and try it otherwise do it from a desktop browser like Chrome.

You can find step by step instructions for installing SmartApp here: http://www.rboyapps.com/InstallSA.htm
if you’ve never installed apps before.


(Steve ) #17

Might sound daft but are you actually clicking and holding on the white text screen under where it says "from code"
When your on android once it’s been copied that’s all you should need to do then it pops up with paste.